Pearl Phono 1 - diagnostic help please - Page 2 - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd May 2012, 12:29 PM   #11
tnargs is offline tnargs  Australia
diyAudio Member
 
Join Date: Sep 2006
Hi, just to update those who generously contributed to my thread:

I replaced the Q4 ZRX450 (again), and still the same voltage measurements, including the base of Q4 being at 1-2 V instead of 13-14 V.

So now I have ordered replacement Q6 and will replace Q4 and Q6 simultaneously. I will let you know how it goes.

cheers
  Reply With Quote
Old 4th May 2012, 05:54 AM   #12
h_a is offline h_a  Europe
diyAudio Member
 
h_a's Avatar
 
Join Date: Sep 2006
Location: Graz, Austria
Typically the jfet blows and takes the ZTX with it; this is the very most common failure for the pearl. In that case replace both as otherwise the remaining damaged jfet will again take down the ZTX.

Quote:
where DO you get a genuine 2SK389?
The K389 is not needed in this position, you can as good use the K170BL or even selected K369GR. These also have twice the power dissipation of the single jfets in the K389, so reliability will no longer be a problem with these replacements.

Hannes

Last edited by h_a; 4th May 2012 at 05:56 AM.
  Reply With Quote
Old 6th May 2012, 02:06 AM   #13
tnargs is offline tnargs  Australia
diyAudio Member
 
Join Date: Sep 2006
Quote:
Originally Posted by h_a View Post
Typically the jfet blows and takes the ZTX with it; this is the very most common failure for the pearl. ....
Ha! NOW I discover this! I have been alternately blowing each one when I replace the other....

Anyway, I have bought 25 K170BL and will replace Q4 (ZTX450) and Q6 (with a matched pair of 170's) together and report back.

Thanks again all.
  Reply With Quote
Old 7th May 2012, 05:50 AM   #14
h_a is offline h_a  Europe
diyAudio Member
 
h_a's Avatar
 
Join Date: Sep 2006
Location: Graz, Austria
Quote:
Q6 (with a matched pair of 170's)
Just for your information - there is absolutely no matching necessary in this position. Of course you can do it if you simply feel like it.

However, use the highest IDSS BL-jfets that you have in this position and you'll get a bit lower distortion.

Hannes
  Reply With Quote
Old 7th May 2012, 10:04 PM   #15
tnargs is offline tnargs  Australia
diyAudio Member
 
Join Date: Sep 2006
Thanks Hannes, will do.
  Reply With Quote
Old 15th May 2012, 03:09 AM   #16
tnargs is offline tnargs  Australia
diyAudio Member
 
Join Date: Sep 2006
Fixed! Replacing both components together did the trick. Measured DC voltages are now as expected.

A quick listen gave the impression of less output on the repaired channel, but this needs to be confirmed.

Thanks again to those who helped!
  Reply With Quote
Old 15th May 2012, 06:04 AM   #17
h_a is offline h_a  Europe
diyAudio Member
 
h_a's Avatar
 
Join Date: Sep 2006
Location: Graz, Austria
Quote:
Fixed!
Great!

Quote:
A quick listen gave the impression of less output on the repaired channel,
Might happen if your jfets are on the other end of the IDSS scale compared to the ones in the other channel, but still the difference should be very small.

Hannes
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help - Balanced Pearl Phono Irakli Pass Labs 15 19th November 2007 03:22 AM
Pearl Phono Preamp bfard Pass Labs 2 26th March 2007 03:25 AM
pearl phono bernification Pass Labs 2 7th February 2006 08:44 PM
Pearl Phono Done (almost) Gregorio Pass Labs 0 16th January 2006 01:42 PM
pearl phono hsort Pass Labs 5 2nd March 2002 09:26 PM


New To Site? Need Help?

All times are GMT. The time now is 05:23 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2