Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Pass Labs This forum is dedicated to Pass Labs discussion.

Is it wrong in F5 TURBO V3?
Is it wrong in F5 TURBO V3?
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd November 2012, 04:51 PM   #11
buzzforb is offline buzzforb  United States
diyAudio Member
 
buzzforb's Avatar
 
Join Date: Oct 2010
Location: Burlington, NC
Have you gotten the non working channel up and running? Any firther ideas of what might b wrong or measurements to help guide members.

BTW, how do you like your Altec onken's. I have a pair of 416a's and 288's waiting for my lazy butt to do something with them.
__________________
...Shape the sound , Man!
  Reply With Quote
Old 23rd November 2012, 06:09 PM   #12
anilva is offline anilva  India
diyAudio Member
 
Join Date: Mar 2004
Location: Bangalore
Quote:
Originally Posted by buzzforb View Post
Have you gotten the non working channel up and running? Any firther ideas of what might b wrong or measurements to help guide members.

BTW, how do you like your Altec onken's. I have a pair of 416a's and 288's waiting for my lazy butt to do something with them.
Thanks. I completed passive measurements of comparing both the channels for PCB continuity as well as component integrity (barring few which cannot be tested by DMM). Everything looks fine after fixing 2 dry solders and one bad connection on P1's centre leg. I have just mounted the board back on the heatsink with other mica+goop paraphernalia. I will power it back and see where it goes. I do have a spare board with components if I cannot trace the problem further. It's been difficult juggling time between family, work and hobby.

I have Altec Onkens built around 515Bs and HF 808's through 811B sectoral horns. They are terrific - driven active by a pair of F5s. Just received Azura horns to be paired with existing 288s. Should be good. Closely following Beyond Ariel. I do have 416As as well.
__________________
DIY F5, F5T, F6, Aleph J, Fostex 206 based BLH, Altec Onken with 515 LF & 288 HF, Technics SP10 MKII & EMT950 turntables
  Reply With Quote
Old 23rd November 2012, 06:28 PM   #13
buzzforb is offline buzzforb  United States
diyAudio Member
 
buzzforb's Avatar
 
Join Date: Oct 2010
Location: Burlington, NC
Excellent selection you have.
__________________
...Shape the sound , Man!
  Reply With Quote

Reply


Is it wrong in F5 TURBO V3?Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
F5 Turbo Builders Thread ungie Pass Labs 4881 Yesterday 06:35 PM
F5 Turbo Circuit Boards chchyong89 Pass Labs 2404 8th October 2017 07:14 PM
F5 Turbo is posted Nelson Pass Pass Labs 636 13th January 2016 11:05 AM
F5 turbo problems Rob Dingen Pass Labs 17 11th January 2013 08:38 PM
F5 Turbo ............. if only !!!!!! a.wayne Pass Labs 23 21st January 2012 02:24 AM


New To Site? Need Help?

All times are GMT. The time now is 05:34 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki