diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Pass Labs (http://www.diyaudio.com/forums/pass-labs/)
-   -   DIY F2 distorting BAD in one channel (http://www.diyaudio.com/forums/pass-labs/187566-diy-f2-distorting-bad-one-channel.html)

hugz 22nd April 2011 02:51 AM

DIY F2 distorting BAD in one channel
 
Howdy


As of yesterday, my F2 has started distorting BAD. It sounds like it's happening mostly in then upper midrange.

It worked fine for years but then recently I decided to finally put a case on it. This required pulling it apart completely and putting it back together.

After being cased up it worked fine for at least a day. Now it's ****** in one channel. Prior to this, it had been on for a few hours, so my guess is that it overheated (since it's now in a case (ie less airflow).

Any thoughts what could be the cause? Ripping off the mosfets will be a [pain, so I'm curious if there's qany likely causes?

Thanks

Hugo

Zen Mod 22nd April 2011 03:24 AM

bad solder joint is first you need to look

unless is seriously overheated

hugz 22nd April 2011 03:39 AM

Quote:

Originally Posted by Zen Mod (Post 2546893)
bad solder joint is first you need to look

unless is seriously overheated

It seems to be getting worse, but I DID slightly fiddle with the wiring sometime before it went bad. Reflowing the joints will be the first order of business, thanks.

Hugo

hugz 22nd April 2011 04:52 AM

Fixed, thanks :)


All times are GMT. The time now is 10:20 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2