Threshold Fet Ten HL/E - balancing issue - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st March 2011, 01:40 PM   #1
albe58 is offline albe58  Italy
diyAudio Member
 
Join Date: Nov 2010
Location: Rome
Default Threshold Fet Ten HL/E - balancing issue

Hi all,
just joined the forum after long and careful reading your very interesting forum!.
I have a Threshold Fet Ten HL/E and a Nakamichi PA-7EII that gives (a lot of) power to a couple of Tannoy HPD 15’’ in a GRF cabinet made by myself.
The overall system sounds (imho) very good and I’m quite satisfied about this “mix” of components (there should be a good synergy among them).

But, there is always something that goes wrong (Murphy theory?)

I recently discovered that the overall sound scene is not balanced properly; I have more “sound” on the left side, so I have to compensate by givin the Fet Ten balance knob 1-2 step more to the right channel.
The strange thing is that the same “behavior” has been found by a friend of mine, who has the same pre Fet Ten HL/E.
Now the question: is anyone that experimented the same problem? Is it something already known about Fet Ten HL/E? is there any solution to fix this issue?


Many thanks for your contributions,
Alberto.
  Reply With Quote
Old 31st March 2011, 02:37 PM   #2
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
if you swap left-right channel interconnect , between amp and preamp , there are two possible scenarios :

weaker channel stays on same side as before - amp need fixing

weaker channel goes to other side - amp is good , and you need same swapping exercise with interconnects - between preamp and source .
same - if , after swapping ICs , weaker channel is still on same side , then preamp is in case and need fixing

in any case - be sure that all interconnect contacts are clean , and that some funny window glass near louder speaker is counted in entire story

__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa...© by Mighty ZM
  Reply With Quote
Old 1st April 2011, 07:30 AM   #3
albe58 is offline albe58  Italy
diyAudio Member
 
Join Date: Nov 2010
Location: Rome
Quote:
Originally Posted by Zen Mod View Post
if you swap left-right channel interconnect , between amp and preamp , there are two possible scenarios :

weaker channel stays on same side as before - amp need fixing

weaker channel goes to other side - amp is good , and you need same swapping exercise with interconnects - between preamp and source .
same - if , after swapping ICs , weaker channel is still on same side , then preamp is in case and need fixing

in any case - be sure that all interconnect contacts are clean , and that some funny window glass near louder speaker is counted in entire story

Hi Zen Mod, thanks for your contribution.
I've already done the suggested checks between pre & amp and between sorce & pre, the result is always the same: problem is on Fet Ten side.
Same situation for the room check (i.e. wall, windows, pictures, etc.): there are no significant differences between left and right side of the room.
Moreover, the same problem is experienced by a friend of mine who has the same preamp but, obviously, in a complete different setup (electronics, speakers, room, etc.).
I think that volume and/or balance knobs could have some problem.
Do you have any hint to better check the issue and establish proper fix?

Alberto
  Reply With Quote
Old 1st April 2011, 07:54 AM   #4
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
unfortunately - I don't have direct experience with Fet10

but - preamp as preamp - you need to examine what's in question - going from back to front ;

so - even output of PC sound card as signal generator , connected via 1K pot and 2u2 cap , Sigjenny program set to 400Hz , and plain DMM as Vac meter connected to output.

inject signal after pot - right in line stage and measure both channels

then move forward - in front of pot , repeat measuring - always comparing two channels

there are many physical variables what's worth checking - almost every physical contact , switch , pot etc.
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa...© by Mighty ZM
  Reply With Quote
Old 5th April 2011, 06:07 PM   #5
diyAudio Member
 
Join Date: Jan 2004
Location: GRASSE (France)
Hi albe58,

I own a Fet-10 He that I have used with many different sources, different amps, different loudspeakers, and I have never faced this problem.

I have performed a significant upgrade on it (refer to this post: Threshold Lovers - Threshold - Fet-10 HE 'competition upgrade') because the Fet-10He can really be a top performer.

I fully agree with Zen Mod: you should follow his instructions to find where the problem comes from... a preamp is a preamp !...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New (to me) Threshold FET-10 HL (What to refurbish?) Redwingnine Pass Labs 103 23rd October 2013 10:10 PM
Threshold Fet nine VS ten marginwalker Pass Labs 19 22nd August 2012 11:40 AM
Threshold FET-10/hl power connector GaryB Pass Labs 5 16th January 2011 08:54 AM
Threshold FET 10/pc Phono Stage Preamp Schematics aka FET 10pc, FET-10pc, fet ten/pc krellkraver Solid State 1 8th February 2007 03:05 PM
Threshold Fet 10/hl Opinion ? ANALOG GUY Pass Labs 6 15th August 2006 05:26 AM


New To Site? Need Help?

All times are GMT. The time now is 03:14 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2