diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Pass Labs (http://www.diyaudio.com/forums/pass-labs/)
-   -   Any upgrades for the Pearl Phono 2SK389 Problem? (http://www.diyaudio.com/forums/pass-labs/183357-any-upgrades-pearl-phono-2sk389-problem.html)

promitheus 17th February 2011 02:25 PM

Any upgrades for the Pearl Phono 2SK389 Problem?
 
A lot of people have had burned 2SK389 in the Pearl Phono.
I wanted to ask if anybody has found a solution for this Problem.
Some say that the problem occures on turn on and the large inrush current burns the 2SK389.
If this true can the parts be protected in any way?

d to the g 17th February 2011 02:36 PM

For me it wasn't a turn on problem, but an issue when you hotswap (don't turn it off the pre and let the caps drain) output cables. The resolution was don't hotswap cables.

promitheus 17th February 2011 02:50 PM

Well normally its not a good idea to swap cables when equipment is still powered on.
I am not sure when the 2SK389BL fail. If it is random or happens under specific conditions.

h_a 17th February 2011 06:06 PM

Hi Promitheus,

long time no see!

Quote:

I wanted to ask if anybody has found a solution for this Problem.
Sure there is; replace them with 2x 2SK170BL that have a higher power dissipation; or, alternatively, replace them with 2x 2SK369GR with changed source resistors and enjoy slightly reduced distortion.

I think I posted the last one with values+measurements somewhere here in Passlabs quite some time ago.

The problem is that some high IDSS 2SK389 run a little too hot in the circuit for good reliability. You can also increase the source resistor and compensate the gain loss by adjusting the load resistor to some extent.

Hannes


All times are GMT. The time now is 03:01 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2