Crackling sound from left channel of X150.5 - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th February 2011, 12:30 PM   #1
diyAudio Member
 
Join Date: Sep 2005
Default Crackling sound from left channel of X150.5

Hi All,

I have a 4-5 yr old Pass Labs X150.5, recently there is crackling noise in the left channel when I power up the amp. The crackling noise goes away after a few minutes, but return intermittently. after reading thru some similar posts, understand that it could be due to cap leakage. May I know where can I find a schematic of the X150.5?

will the cap leakage cause any further damage if I leave it unattended?

also for amps like X150.5, what is the expected lifespan? 10 years? 20 years? considering I am from a humid tropical country .

Thank you.
  Reply With Quote
Old 7th February 2011, 02:14 AM   #2
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
I have not encountered this, and have no reason to assume
that it's a leaky cap.

I suggest that you let the factory or distributor fix it.

The probably life span before needing new power supply caps
is about 20 years or so. We have 20 year old Alephs still
performing as original.

  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crackling noise in left channel. fritz39 Solid State 1 20th January 2009 11:57 PM
When Volume up - left channel sound prob ? Krokotam_ Solid State 7 21st October 2008 02:55 AM
crackling sound from one channel ali_azamkhan Tubes / Valves 4 23rd November 2007 09:43 PM
Tube Amp - Crackling Sound on Left Channel Noak Tubes / Valves 8 28th December 2005 01:46 AM
Crackling sound in right channel of TDA1541A DAC HeadSh0T Digital Source 3 9th December 2003 10:16 PM


New To Site? Need Help?

All times are GMT. The time now is 11:34 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2