Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Pass Labs This forum is dedicated to Pass Labs discussion.

High distortion at startup in X150.5
High distortion at startup in X150.5
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd January 2011, 06:41 PM   #1
parsecaudio is offline parsecaudio  Italy
diyAudio Member
 
Join Date: Apr 2004
Location: ventimiglia
Default High distortion at startup in X150.5

Hello to all.
A friend of mine have a Passlab X150.5 power amp.
This unit has a problem:a high distortion in right channel for 5-6 minutes after the power on(the other channel is OK).
The distortion seems in the channel that drive the VU-Meter.
Is a faulty on the unit or is a normal behavior?
Thank you
  Reply With Quote
Old 23rd January 2011, 04:26 AM   #2
Nelson Pass is offline Nelson Pass  United States
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
High distortion at startup in X150.5
Sounds to me like it might need service.

Is this a subjective evaluation, or are you using a distortion analyzer?

  Reply With Quote
Old 23rd January 2011, 09:02 AM   #3
parsecaudio is offline parsecaudio  Italy
diyAudio Member
 
Join Date: Apr 2004
Location: ventimiglia
Thank you Mr Pass
The distortion is very high,no analizer is needed for this evaluation.
The sound is like an overload clipping,at any level of listen.
  Reply With Quote

Reply


High distortion at startup in X150.5Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Will lightbulb protect my amp from to high idle current at startup? seafire Solid State 5 18th September 2009 05:37 PM
high frequency distortion paul_peraic Parts 2 7th May 2008 03:48 PM
Turntable High Frequency Distortion Sibilance Signal Analogue Source 1 8th January 2008 06:09 PM
High Distortion on Aleph 5 Jaac Pass Labs 12 2nd June 2007 02:29 AM
Is there a no/gain preamplifier schematic using high-distortion EC90? Layberinthius Tubes / Valves 6 10th May 2004 06:13 AM


New To Site? Need Help?

All times are GMT. The time now is 11:59 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki