Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Pass Labs This forum is dedicated to Pass Labs discussion.

Blown outputs (maybe?) in my Forte'  3 amp.
Blown outputs (maybe?) in my Forte'  3 amp.
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th August 2010, 08:11 PM   #1
gullaz is offline gullaz  Italy
diyAudio Member
 
Join Date: Jul 2010
Location: bologna, italy
Default Blown outputs (maybe?) in my Forte' 3 amp.

Hello to all Pass Labs forum users. This is my first post on Diyaudio.
I have blown three output transistors on my recently acquired Forte' amplifier while trying to adjust the bias...
The amplifier was running rather cooler on one side so I opened it and tried to correct the difference measuring the amperes... Result: three devices on the left channel are probably gone as well as two of the emitter resistors and when I try to power it up it blows both fuses.
As a total noob I was very imprudent to mess with something I don't know...
Now my problem:
As original toshiba outputs are difficult to find
(they are 2SC3281/2SA1302) I have found out that possible replacements are 2sc5200/2sa1943... In this case may I replace only the three blown outputs with the new equivalents or should I replace all the devices in the left channel or, worse, replace all the devices in both channels (ouch!!).
Sorry for posting such a simple and banal question but I thought that here there might be many users that know this amplifier and can advice me for the best.

Thanks in advance for any kind answer you will give me.
  Reply With Quote
Old 9th August 2010, 08:20 PM   #2
Nelson Pass is offline Nelson Pass  United States
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
Blown outputs (maybe?) in my Forte'  3 amp.
Likely you could replace just the blown devices without
problems. Most audiophiles would be bothered by the small
asymmetry of such an approach (or by a splice in their
speaker wire).

  Reply With Quote
Old 9th August 2010, 08:35 PM   #3
gullaz is offline gullaz  Italy
diyAudio Member
 
Join Date: Jul 2010
Location: bologna, italy
Thanks a lot for the answer mr. Pass, I was only concerned by possible reliability issues... This cheers me up a lot: I'll change the burned devices only (and control the left channel bias trimmer which was probably gone.
  Reply With Quote

Reply


Blown outputs (maybe?) in my Forte'  3 amp.Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to repair Samson SX1200 w/ blown outputs on one channel jamesmafyew Solid State 25 24th April 2016 09:56 AM
Denon PMA-520 Blown Outputs Perhaps DreadPirate Solid State 1 3rd May 2010 08:30 PM
LANEY B1 Amp - Blown outputs technotronic Class D 0 17th April 2009 07:42 PM
Balanced outputs used as inverting & Non-inverting preamplier outputs gni Solid State 4 19th September 2008 03:25 AM
FS Forte' FT1 5ch amp and model 3 power amp bender460 Swap Meet 5 13th October 2005 09:17 PM


New To Site? Need Help?

All times are GMT. The time now is 02:49 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki