Forte model 40 phono stage fault - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th November 2009, 06:50 AM   #1
cc1961 is offline cc1961  Australia
diyAudio Member
 
Join Date: Nov 2009
Location: Victoria.
Question Forte model 40 phono stage fault

Hello folks,
i am new to this diyaudio, forgive me if this is not the correct procedure,
currently i am trying to find a fault in my Forte model 40 phono stage it plays
for a while then powers off for a few seconds then comes back on.
have looked for dry solder joints etc, anyone come across this type of fault before.

regards,
Craig
  Reply With Quote
Old 18th November 2009, 08:35 PM   #2
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
Sounds like a supply fault. I would monitor the DC
rail voltages on the supply - as I recall, if the rails fall too
low, the relays open.

  Reply With Quote
Old 18th November 2009, 09:07 PM   #3
cc1961 is offline cc1961  Australia
diyAudio Member
 
Join Date: Nov 2009
Location: Victoria.
Thank you, i will check voltages, the main relay is not opening when phono stage cuts out. I would really be gratefull if you could supply copy of manual or circuit diagram.

regards,
Craig
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Forte' audio model two preamplifier saperusa Pass Labs 4 23rd August 2012 01:09 PM
Forte Audio Model ONE WolfgangL Pass Labs 1 23rd February 2011 01:04 PM
Forte Model 2 Preamp phono opamp selection Daveis Pass Labs 0 11th January 2009 05:34 PM
Forte Model 4a Heiney9 Pass Labs 3 16th July 2007 08:44 PM
FS Forte' FT1 5ch amp and model 3 power amp bender460 Swap Meet 5 13th October 2005 09:17 PM


New To Site? Need Help?

All times are GMT. The time now is 11:02 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2