Fuse value for Threshold Fet/10 He - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th May 2009, 10:35 AM   #1
diyAudio Member
 
Join Date: Jan 2004
Location: GRASSE (France)
Default Fuse value for Threshold Fet/10 He

Hello friends,


I have a (old but still excellent) THRESHOLD Fet/10 He preamplfier, and I would like to know the Fuse value.

I have of course removed it from the power supply, but it is almost impossible to be sure of what is written on the fuse.

I can read:
250 V (this is normal as I live in France)
F3

but after, it is difficult to identify if it is 5A or 15A.

Does any of you know ?

Thanks
  Reply With Quote
Old 8th May 2009, 02:33 PM   #2
The one and only
 
Nelson Pass's Avatar
 
Join Date: Mar 2001
Probably .5 A fast blow.

  Reply With Quote
Old 9th May 2009, 10:40 AM   #3
diyAudio Member
 
Join Date: Jan 2004
Location: GRASSE (France)
Do you mean 0.5 A or 5A ?

Thank you very much for your time and for all you give to this forum...and to the High Fidelity !

Nounours
  Reply With Quote
Old 13th February 2010, 08:18 PM   #4
diyAudio Member
 
Join Date: Jan 2004
Location: GRASSE (France)
Quote:
Originally Posted by Nounours18200 View Post

Thank you very much for your time and for all you give to this forum...and to the High Fidelity !

Nounours
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Threshold SA/12e Danish Pass Labs 16 23rd February 2010 02:21 AM
Threshold sl-10? jonk Pass Labs 14 23rd November 2008 08:21 AM
Fuse housing melting but fuse not blowing, ppi amp rawadia Car Audio 21 2nd August 2008 10:39 AM
Why main fuse and not rail fuse? digital desire Solid State 10 3rd December 2006 08:07 PM
amp rating for fuse and fuse holder? riotubes Parts 5 27th August 2006 03:10 AM


New To Site? Need Help?

All times are GMT. The time now is 12:36 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2