UGS Power : it's U.P. - Page 34 - diyAudio
Go Back   Home > Forums > Amplifiers > Pass Labs

Pass Labs This forum is dedicated to Pass Labs discussion.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th March 2013, 12:53 PM   #331
diyAudio Member
 
Join Date: Jan 2006
Location: North west England
Is it OK to use KSA1381/KSC3503 as replacements for 2sa1209/2sc2911? I have contacted Zhoufang to see if I can still get 2sa1209/2sc2911, but KSA1381/KSC3503 are readily available Mouser.
  Reply With Quote
Old 9th March 2013, 07:17 PM   #332
rade95 is offline rade95  United States
diyAudio Member
 
Join Date: Apr 2010
Location: Boulder, Colorado
Does anyone have a pair of UGS-UP PCBs for sale?
__________________
UGS pre, stock F5, PassLabs X2.5, Aleph P
  Reply With Quote
Old 29th March 2013, 11:04 AM   #333
Yunick is offline Yunick  Sweden
diyAudio Member
 
Join Date: Mar 2006
Location: Gussjö
Hello,

Some time ago I finished my copy of the U.P. The pcb’s came from one of the French group buys and I followed the instructions given in the French document during the assembly.
I haven’t listen to the amp very much until recently. I took my Aleph-J and U.P to a friend over the weekend and we did a lot of A-B test. I was not really happy with the sound of the amp. Well compared to the A-J the total presentation is brighter and thinner. The soundstage is not as big and it’s difficult to pinpoint instruments and musicians.
During the this tests we switched between two types of speakers. One regular 2-way box spkr and a tangband 4” in a TL. Source was UGS pre-amp and DAC-END connected to a squeezebox.
What the amp is phenomenal at is bass. Tight, fast and with great authority.
When I assembled the amp I didn’t use the best possible matched mosfets. I bought them already matched but didn’t measure them until after I powered the amp. I measure between 0.09-0.14V across the source resistors. I didn’t match any of the transistors for the front end…

I expected the "sound" to be better then the A-J. Could the mismatched mosfets be the "problem"?
Attached Images
File Type: jpg A-j_800x400.jpg (192.9 KB, 338 views)
File Type: jpg ugs_up_inside.jpg (187.4 KB, 324 views)
File Type: jpg Source.jpg (151.4 KB, 307 views)
File Type: jpg ugs_up_complete.jpg (188.1 KB, 285 views)
  Reply With Quote
Old 29th March 2013, 02:05 PM   #334
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
it's easy to test matching issue :

using light load ( 4" tangband) ,try with disconnected (pulled from circ , easiest with desoldering one end of source and one end of gate resistor per mosfet) all but one output mosfet per quadrant (so having just 4 per channel) ....... if sound is the same , regarding mid and highs , matching isn't problem

however - generally speaking for amp , be sure that you're having all operating points exactly where they need to be ( currents , voltages)
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa...© by Mighty ZM
  Reply With Quote
Old 1st April 2013, 08:33 AM   #335
Yunick is offline Yunick  Sweden
diyAudio Member
 
Join Date: Mar 2006
Location: Gussjö
Thanks Zen Mod,

I'll try eliminate mismatch problem first.
Then to find operating pionts may be a bit more challenging. I think I remember Cheff posted a picture from a sim with voltages and current for the UGS front ends. But I think it was using a few different parts and I can't find it now..
  Reply With Quote
Old 30th July 2013, 03:34 PM   #336
diyAudio Member
 
Join Date: Jan 2006
Location: North west England
Hi everyone,

I have just put together one channel of UP but have hit a snag and need help. I have carefully followed the manual v2. Everything was going according to spec until I installed the 22000 caps and output devices. On power up, the manual says to check voltage va where I should be getting 24v. I did so up to this point, however now I'm only getting about 9v! Is there a likely cause?

Your help would be very much appreciated

Thanks
  Reply With Quote
Old 30th July 2013, 04:05 PM   #337
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
pics
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa...© by Mighty ZM
  Reply With Quote
Old 30th July 2013, 05:02 PM   #338
diyAudio Member
 
Join Date: Jan 2006
Location: North west England
Hope you can make this out.
Attached Images
File Type: jpg IMGP0116.jpg (777.1 KB, 156 views)
  Reply With Quote
Old 30th July 2013, 05:05 PM   #339
diyAudio Member
 
Join Date: Jan 2006
Location: North west England
Another.
Attached Images
File Type: jpg IMGP0117.jpg (820.5 KB, 108 views)
  Reply With Quote
Old 30th July 2013, 05:41 PM   #340
diyAudio Member
 
Join Date: Jan 2006
Location: North west England
I should point out that I have used some substitute parts:

KSC3503
KSA1381
FQA16N25C
FQA12P20

But these are all pin compatible.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
40A 250V Schottky Power Diodes- Has anyone use in Power Amp to replace Diode Bridge? dtm1962 Solid State 10 15th September 2011 07:38 PM
LTspice tool for power amp power supply component evaluation andy_c Software Tools 2 23rd August 2009 05:10 PM
Power transformers versus amplifier output power..what is your option? destroyer X Solid State 38 9th May 2009 05:23 PM
Amplifier 3000 Wats Rms Power + Smps Higcht Power Bestiality MARAVILLASAUDIO Class D 1 5th November 2004 04:06 PM
power output calculations, rated power and required power output metebalci Tubes / Valves 7 22nd February 2004 05:49 PM


New To Site? Need Help?

All times are GMT. The time now is 07:08 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2