Technics suv4x - diyAudio
Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd February 2007, 04:05 PM   #1
dovi is offline dovi  Israel
diyAudio Member
 
Join Date: Feb 2007
Location: Countryside
Default Technics suv4x

First thread for me - EVER.
Just off the flee market after buying a nice and cleaned technics suv4x amp.
Considering myself a seasoned electronis engineer with lots ( apperantly not long enough ) of experiance i bought this at about 15$ knowing I can't fail this.
And o did i fall.
The thing was previosly dealt by an expert: the power section -which is a double class A amp in a single package was missing. And certainly unavailable anymore exept for imprint copycats.
Has anyone done a convertion to chipamp with good results to a similar amp?
Its so nice inside - with heat piping and good power supply -shame to throw it away - not to mention the loss of face and faith in myself.
I know I deserve it
but seriously now - anyone with similar problem/ answer?

Dovi
  Reply With Quote
Old 2nd February 2007, 04:56 PM   #2
diyAudio Member
 
FastEddy's Avatar
 
Join Date: Jun 2006
Location: North Californie
$15 !! Looks like a great bargin assuming the PS and parts still work.

" ... Has anyone done a convertion to chipamp with good results to a similar amp? ... Its so nice inside - with heat piping and good power supply -shame to throw it away ..."

I can't find any decent pictures online of the interior of your suv4x, but FYI: I did a nice similar upgrade to an old Crown amp using power MOSFET mudules ( http://3dotaudio.com/ampics.html ) ... keeping all the perfectly useful hardware and torrid xformer, etc.

(IMOP: discrete input power MOSFET amps sound somewhat better than "chip amps" ... but others may disagree.)

  Reply With Quote
Old 20th February 2007, 07:35 AM   #3
aman is offline aman  India
diyAudio Member
 
aman's Avatar
 
Join Date: Mar 2004
Location: delhi
Default technics,sux90

hi dovi
I too bought a second hand technics amp su x90 a few day back and thought i could repair it. When i opened it everything was intact but when i powered it up there was no display on the FLT and none of the micro swithces on the front panel is working.The front panel is fully digitally controlled. I also change the chip lm6402h(microcomputer chip,RAM,ROM etc.)throught which wires of the swithces are comming but there was no result after tinkering for 3-4 days.The output IC svi2004a is ok as it is giving the output hissing when i touch the inputs with a pair of twizzers.
Now i m out of ideas in finding the fault and there's no working su-x90 nearby to swap the components to find out the faulty one and i dont have the schematic of amp. If any of the friend of diy community have the schematic plea.........se mail it to me at aman_4g@yahoo.com
I have seen a part of the schematic of su v4x amp.It also use the svi2004a (class a amp) chip.This amp has rotary controls on the front panel whereas the su x90 has got digital controls and a cute dispaly of spectrum analyser and 7 band graphic equalizer controlled by lm6402h chip.
Aman,india
  Reply With Quote
Old 7th August 2007, 01:07 PM   #4
diyAudio Member
 
SVI2004A's Avatar
 
Join Date: Mar 2004
Location: Albany Western Australia
Send a message via MSN to SVI2004A
heh i have schematics for both those amplifiers,

have 3 SU-X90s and a 4th playing up (minor -15V reg problem)
__________________
.:Ride the Lightning...Feel the Thunder:. - Technics Triple Thunder www.welcome.to/Technics oh yes ppl plz send me them dead (or Alive) STK or SVI ICs
  Reply With Quote
Old 10th August 2007, 12:07 PM   #5
aman is offline aman  India
diyAudio Member
 
aman's Avatar
 
Join Date: Mar 2004
Location: delhi
Default svi2004a

hi ,
could u plz send me the schematic of both amplifiers coz my x90 is still lying dead.
it would be a great help to me
rgrds [email]Aman_4g@yahoo.com[/email
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Technics SA-600 ZigDaPig Solid State 0 16th August 2005 01:33 PM
Technics SA-500 ZigDaPig Solid State 6 20th May 2005 03:36 PM
Technics SU-Z22 Rob Flores Parts 0 18th March 2005 01:12 PM
Which Amp to keep - Technics or NAD? maxw Solid State 5 6th December 2004 10:41 AM
DJs and Technics davesaudio Analogue Source 2 3rd November 2004 01:46 AM


New To Site? Need Help?

All times are GMT. The time now is 11:11 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2