Eico 950B - diyAudio
Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd May 2006, 01:21 AM   #1
imix500 is offline imix500  United States
Proud Union Member
diyAudio Member
 
imix500's Avatar
 
Join Date: Mar 2004
Location: Nashville, TN
Default Eico 950B

Hello all, so I just purchased this handy piece of equipment and on my first night of using it after checking its internals out, I had an incident.
I was using the electrolytic capacitor test fuction to check leakage on a 450v 1200uf cap and once the test had completed, I turned the voltage pot to zero to discharge the cap. A second later there was a loud pop and the magic eye went out.
I found that the 560v winding of the transformer had blown open. How could this have happened?
I will try to attach the schematic but it's in djvu format. Thanks!
  Reply With Quote
Old 28th August 2009, 12:12 AM   #2
diyAudio Member
 
Join Date: Dec 2007
Send a message via AIM to kyleaudio
i just managed to do the same thing, i charged up a 2400uf 375v cap, all went, when it was fully charged i turned the voltage pot back to 0 as it says to do in the instruction manual and POP! there was a bright white spark in the tube, the green eye went out right away and there was a metalic rattle sound. i blew the 1629 tube badly, there are now things rattling arround inside, somehow the back metal case of the 100k 4 watt power potentiometer blew off and hit the back of the case and chipped the paint! my transformer seems to still be working as it should, however my power pot no longer works. anybody know where i can find a new 100k 4w wirewound pot?
  Reply With Quote
Old 28th August 2009, 01:36 AM   #3
imix500 is offline imix500  United States
Proud Union Member
diyAudio Member
 
imix500's Avatar
 
Join Date: Mar 2004
Location: Nashville, TN
It's funny, I was just looking at one on fleabay to use for parts. Never got around to fix the old one. 100k 4W pots are available from Newark for... $103 Ouch.
  Reply With Quote
Old 28th August 2009, 01:41 AM   #4
diyAudio Member
 
Join Date: Dec 2007
Send a message via AIM to kyleaudio
WOW!!! well i guess mine might just turn into spare parts or just sit arround till i find a cheap 100k 4w. i only paid $10 for it, so i dont think $103 and a new tube is worth it...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
help w/ Eico hf-81 paulnparis Tubes / Valves 3 29th August 2009 12:57 PM
EL-34 instability in EICO HF-35 amp ltarini Tubes / Valves 0 26th September 2007 05:43 PM
Eico HF-32 crick Parts 3 25th June 2007 01:18 AM
12a?7 in Eico HF-12 ivegotmono Tubes / Valves 7 24th March 2006 03:52 PM
WTB: Eico HF-81 mrdon Swap Meet 0 20th October 2005 02:02 AM


New To Site? Need Help?

All times are GMT. The time now is 01:39 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2