Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Right Channel not working on Stereo reciever
Right Channel not working on Stereo reciever
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th November 2005, 03:33 AM   #1
nicku1302 is offline nicku1302  United States
diyAudio Member
 
Join Date: Nov 2005
Location: us
Default Right Channel not working on Stereo reciever

Hey everyone, i have a Technics AV stereo reciever(SA-EX110) class H+ and the right channel just stopped working one day. It is a 300 W receiver with 2 sets of stereo outputs. One set of outputs can only be run at a time A or B. I tried using the second set of outputs(outputs B)but only the left channel works still just as in stereo outputs A. I also tried to alter the balance all the way to the right channel but nothing comes out. I opened it up and saw no visible signs of blow out caps or resistors....Can anyone help me fix this ?? It's crucial that i get this working or my house parties will be no more... thanks
  Reply With Quote
Old 29th November 2005, 03:32 AM   #2
anatech is online now anatech  Canada
diyAudio Moderator
 
anatech's Avatar
 
Join Date: Jun 2004
Location: Georgetown, On
Right Channel not working on Stereo reciever
Hi nicku1302,
Are you good with a soldering iron?

Technics are famous for many bad solder joints on the jacks at the rear of the board and also the parts that mount to the heatsink. Do yourself a favour and use liquid solder flux (for PCB work!). Add very little solder and redo all of these. Also watch the fan connections.

If you aren't good with a soldering iron, have someone do this that is good. Use a good temp. controlled iron.

-Chris
  Reply With Quote

Reply


Right Channel not working on Stereo recieverHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New K-12g only one channel working audioblast Tubes / Valves 9 14th May 2007 02:13 PM
WTB: Stereo Reciever, Plate Amp, CSS FR125S Evazan Swap Meet 9 28th September 2006 05:35 AM
bridging channels on stereo reciever 9am53 Solid State 10 8th December 2005 04:16 PM
stereo hifi project with fm reciever gideon Chip Amps 2 24th October 2005 07:38 PM
My Stereo Encoder Design not working -- PLS HELP..! xitronics Everything Else 11 28th May 2005 04:51 PM


New To Site? Need Help?

All times are GMT. The time now is 04:19 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki