Logitech Z-5500 Subwoofer Toroidal Transformer Hum Noise - diyAudio
Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 5th April 2014, 03:35 AM   #1
diyAudio Member
Join Date: Apr 2014
Default Logitech Z-5500 Subwoofer Toroidal Transformer Hum Noise

Hi everyone,

I've been having some trouble with my Logitech Z-5500's and I was hoping I could get some advice from you knowledgeable folks!

I noticed a low buzzing sound coming from the subwoofer box and it turned out to be coming from the toroidal transformer. (I originally thought it was coming from the sub itself because of magnetic interference from the transformer but it's coming from the actual transformer.) The hum starts when the switch in the back of the sub is turned on even when there is nothing other than the power cord plugged into the system. It seems like whenever the transformer is powered it makes noise.

The brand name on the transformer is TENPAO and the model number is TOU543005F0.

I was wondering if someone has an idea of what is causing the hum or a suggestion for what could be done to stop the transformer from humming?

Thank you!
  Reply With Quote
Old 6th April 2014, 06:17 PM   #2
diyAudio Member
Join Date: Apr 2014
Location: WV
Mount it to a rubber block, fill it with silicone, or hot glue. It's probably not bad. Just noisy.
  Reply With Quote
Old 6th April 2014, 07:10 PM   #3
diyAudio Member
Join Date: Apr 2014
Thanks for your reply.

I can hear the noise from across the room. Is that type of hum normal?
  Reply With Quote
Old 27th March 2015, 10:23 PM   #4
diyAudio Member
Join Date: Mar 2015
I have the same problem. How did you fix it?
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help required on Logitech Z-2300 toroidal transformer RishiGuru Parts 40 1st October 2014 04:40 AM
Logitech Z-5500 amp chengbin Chip Amps 1 2nd February 2012 12:50 AM
Logitech Z-5500 Amp Troubleshooting TooManyUsers Chip Amps 6 23rd December 2011 02:51 PM
Need Replacement cables for Logitech z-5500 irishred Everything Else 0 13th September 2011 08:43 PM
TDA7294 based logitech z 5500 Edmunds Chip Amps 10 2nd October 2010 09:41 PM

New To Site? Need Help?

All times are GMT. The time now is 10:32 PM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2