Nikko power amplifier alpha II relay - Page 2 - diyAudio
Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 15th July 2013, 07:58 PM   #11
kocozze is offline kocozze  Italy
diyAudio Member
Join Date: Feb 2012
i will careful...having said that, i have a last minute update. I turn it off all!! With no music in play the right channel makes strange noises intermittent, with the Vu Meter right that rises and falls many time, alone, without any input...oh oh, it's better that i do not use anything?
  Reply With Quote
Old 15th July 2013, 08:07 PM   #12
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
Mooly's Avatar
Join Date: Sep 2007
Its very difficult to say what is going on with it at a distance. Given the age of it you might have problems with old electrolytic capacitors having dried out, and problems with dry joints (poor soldering).

The only answer I'm afraid is to test it properly with a scope and signal source to determine what is happening.

The output relay is a very specific part and gives specific faults, but if you are doubtful over it then you have to eliminate it.
Installing and using LTspice. From beginner to advanced.
  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nikko Power Amplifier Alpha II Stuck On Protect Jkohuts Solid State 13 19th July 2015 04:19 PM
Problems with Nikko Alpha II Power amp (protection cuts off) tomzern Solid State 2 26th January 2010 08:32 PM
Who knows the Nikko Alpha II ? ginetto61 Solid State 4 20th October 2009 05:45 PM
Nikko Alpha Ii Schematic east electronics Solid State 6 11th June 2009 11:42 AM
Nikko Alpha II amp troubleshooting livetoski Solid State 58 22nd February 2007 06:11 PM

New To Site? Need Help?

All times are GMT. The time now is 02:18 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2