Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th June 2013, 04:29 PM   #1
diyAudio Member
 
Jimmy154's Avatar
 
Join Date: Jun 2002
Location: NH, USA
Default Trying to build an o2 sensor simulator but car forums are a bad place to ask . . .

about electronics. There aren't many people knowledgeable in electronics on automotive forums, so I'm hoping some one here will help me

I'm trying to build this:

O2 Sensor Simulators - Complete Guide - MY350Z.COM Forums

or this:

O2 sensor simulator - Mechanical Database

I don't know which one might be better to build, but unless some one tells me otherwise I will go with the first one since the parts list matches the schematic and also the schematic makes sense to me. Well everything expect there seems to be one signal output and my o2 sensor has 4 wires. Two of them a resistor goes across, I get that part, but which of the retaining two wires do I hook this device to if it only has one output? Or maybe I should ask if it has one output?

Then I'm wondering if I can use only simulate one o2 sensor with one device or can I use one device for both o2 sensors? Basically can the signal be sent to both o2 sensor wiring harnesses and still remain the same?
__________________
We do not allow political statements or conjecture to be made on these forums.---the diyAudio moderation team
  Reply With Quote
Old 19th June 2013, 04:54 PM   #2
diyAudio Member
 
Join Date: Nov 2005
You could try looking at the megasquirt manual and forum. There you'd find people that know both engines and electronics, and plenty of answers. The link in the man page to the O2 sensor wiring list seems to be broken though. Are you working on a 350Z ?, because there are two fundamentally different sensor types, wide and narrow band and simulators would be entirely different for each.
  Reply With Quote
Old 19th June 2013, 05:23 PM   #3
diyAudio Member
 
Join Date: Nov 2008
Location: Victoria,TX
Blog Entries: 1
Hi,
For your information.
Normally the O2 sensor send a voltage output from zero to .98 volts to the MCU. The 4 wires O2 sensor two of the wires are for the heater and the other two wire are for the voltage output to the MCU. What the tester does it is fooling the MCU that you have a O2 sensor connected. If you do not have the sensor connected then the computer will turn on the engine fault light ON. By connecting the tester the MCU would see the sensor it is connected no fault light. Normally a good engine running the oxygen voltage output it is about .5 volts. Higher means the engine it is running lean and below means that the engine it is running rich. By reading the O2 sensor voltage you can adjust the fuel/air ratio for better mileage.
  Reply With Quote
Old 19th June 2013, 08:30 PM   #4
diyAudio Member
 
Jimmy154's Avatar
 
Join Date: Jun 2002
Location: NH, USA
Quote:
Originally Posted by Andrew Eckhardt View Post
You could try looking at the megasquirt manual and forum. There you'd find people that know both engines and electronics, and plenty of answers. The link in the man page to the O2 sensor wiring list seems to be broken though. Are you working on a 350Z ?, because there are two fundamentally different sensor types, wide and narrow band and simulators would be entirely different for each.
Yeah sometimes today that page has been down, but I just refreshed it and it came back up pretty quick.

No, I have a 2002 Passat 2.8l v6.
350Z would be preferable though

I've figured most of the wiring out, except I have LED's rated for 1.8v, but I don't know if that is the "drop voltage".

What I haven't figured out is if this will work on my passat.
two white wires are + for the heat, grey is negative and black is signal and the black wires from both o2 sensors go to the signal output of the circuit.
__________________
We do not allow political statements or conjecture to be made on these forums.---the diyAudio moderation team
  Reply With Quote
Old 19th June 2013, 08:38 PM   #5
diyAudio Member
 
Join Date: Nov 2008
Location: Victoria,TX
Blog Entries: 1
Hi,
You can take a 1.2 volt battery and a variable resistor and adjust the voltage to .5 volts and it should work. Now this is for 2 or 4 wire O2 sensors. There also lambda sensors that give you the percent of oxygen in the exhaust. They used more than 4 wires. One thing that you have to have in mind it is that the output should be changing. A solid voltage will no work. That it is why they use the LM555. The output need to be changing constantly.
  Reply With Quote
Old 19th June 2013, 10:08 PM   #6
diyAudio Member
 
Jimmy154's Avatar
 
Join Date: Jun 2002
Location: NH, USA
Quote:
Originally Posted by tauro0221 View Post
Hi,
For your information.
Normally the O2 sensor send a voltage output from zero to .98 volts to the MCU. The 4 wires O2 sensor two of the wires are for the heater and the other two wire are for the voltage output to the MCU. What the tester does it is fooling the MCU that you have a O2 sensor connected. If you do not have the sensor connected then the computer will turn on the engine fault light ON. By connecting the tester the MCU would see the sensor it is connected no fault light. Normally a good engine running the oxygen voltage output it is about .5 volts. Higher means the engine it is running lean and below means that the engine it is running rich. By reading the O2 sensor voltage you can adjust the fuel/air ratio for better mileage.
I thought the two white wires were the positive to the heater and the grey was the negative for the heater and the black was the signal wire. If this is wrong than I am lost again

Okay here it is:

Black: signal output
Gray: signal ground
white wires: heater

In the schematics I only see one signal output. Where does the o2 ground go?
I think I know how to wire it. I always seem to have trouble with schematics output symbols.
And grounds too. Let me upload the schematic and see if i have it right.
Where do I connect the o2 sensor signal ground? Does it need to be connected from the harness to anything?
Attached Images
File Type: jpg O2_simulator_diagram copy.jpg (54.6 KB, 165 views)
__________________
We do not allow political statements or conjecture to be made on these forums.---the diyAudio moderation team

Last edited by Jimmy154; 19th June 2013 at 10:37 PM. Reason: stupidity
  Reply With Quote
Old 20th June 2013, 05:58 PM   #7
diyAudio Member
 
Jimmy154's Avatar
 
Join Date: Jun 2002
Location: NH, USA
Does the o2 sensor ground go to the battery ground, as well as the "ground" for the circuit?

Maybe I should ask another way: when I'm testing the circuit output do I ground the ground of the DMM to the battery ground?

Sorry if these questions sound super stupid?
__________________
We do not allow political statements or conjecture to be made on these forums.---the diyAudio moderation team
  Reply With Quote
Old 20th June 2013, 07:07 PM   #8
diyAudio Member
 
Join Date: Nov 2008
Location: Victoria,TX
Blog Entries: 1
Hi,
To double check the connections take your O2 sensor and check the cables with an ohmmeter. Check one of the black wire with the others. If you read low resistance means it is the heater. Then check the other wire for voltage. It should read a low millivolt reading.

Normally you have two grounds one for the heater and one for the O2 sensor. Each one have an individual ground.

I used to build O2 sensor bar graph display using the LM3914. It is a 10 led display. That was long time ago.
  Reply With Quote
Old 20th June 2013, 08:36 PM   #9
diyAudio Member
 
Jimmy154's Avatar
 
Join Date: Jun 2002
Location: NH, USA
I don't have rear o2 sensors at all.
I can check the front ones.
Across the heater wires I will wire a 8 ohm resistor I suppose. To the black wire (o2 signal) will go the output from the circuit in the image.
I'm kind of unsure if I need to wire the o2 sensor ground to my battery ground lead or chassis. All these connections go to the ECU, I don't have any o2 sensors in the rear.

I bought a car and to my surprise when I got it home and changed the oil I noticed it was missing cats and rear o2 sensors/wires. Funny thing is that even when I worked as a car inspector I would never look under the cars even though it was technically part of my job description.
__________________
We do not allow political statements or conjecture to be made on these forums.---the diyAudio moderation team
  Reply With Quote
Old 20th June 2013, 09:27 PM   #10
diyAudio Member
 
Join Date: Nov 2008
Location: Victoria,TX
Blog Entries: 1
Hi,
I do not know about the heater connection but really the one you need it is the voltage from the O2. Now I do not know if the MCU it is reading the current going to the heater or not and then turn on the engine fault light. Just try connecting the O2 and see if the MCU see it.

Suggestion try to find which O2 use your car and then see if you can find the connector wire assignments.

I have on hand a O2 sensor and the heater read 5 ohms.
The heater wire colors are white/white and the O2 are gray/black
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Building the O2 - A novices build experience fineaudiolover Headphone Systems 0 1st June 2013 10:09 PM
http://www.diyaudio.com/forums/analog-line-level/181105-mezmerize-build.html#post2432 AndrewT Analog Line Level 0 14th January 2011 11:11 AM
Bad Car Amps Gone Worse... sousmielie Car Audio 25 28th June 2008 10:39 AM
I want to build car smps and car amplifier himanshuraval Car Audio 0 20th February 2004 12:40 PM


New To Site? Need Help?

All times are GMT. The time now is 02:04 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2