Quick question about op-amps - diyAudio
Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th September 2003, 10:02 AM   #1
diyAudio Member
 
Hybrid fourdoor's Avatar
 
Join Date: May 2003
Location: Ft. Worth, TX
Default Quick question about op-amps

Im messing around with Circuit Maker and when I place op-amps I can just rename an op-amp right? I mean as long as they have the same kind of inputs they theoretically should operate the same. Like a 8 pin op-amp is the same as another 8 pin op-amp. The differences are gonna be how well in real life they actually perform as an ideal op-amp. Like when it says UA741, I can easily just rename it NE5532 (with the assumption its only representing one side of a NE5532), and it should still come out the same right?

Thanks,
David
  Reply With Quote
Old 27th September 2003, 04:12 PM   #2
diyAudio Member
 
purplepeople's Avatar
 
Join Date: Mar 2003
Location: London, Ontario, Canada
Default Any CM pros out there?

If we forget that you are using EDA software for a minute and can probably get the actual SPICE model for the specific opamp somewhere...

It's my understanding that since the 741 was introduced, opamps have been such excellent and consistent devices that the signals they produce are almost entirely controlled by the resistors that surround them. We design a circuit with the "ideal" opamp then choose the IC to match the input and output signals we need.

The 5532 is a dual and will have the added problem of channel separation but it is a good device. Maybe CM has a generic dual opamp you can use... it may help with the PCB layout. If you can get the spice model, it might give very slightly different simulations vs. the "ideal" opamp. I haven't used CM in a long time, so I can't be quite sure. Any CM pros out there?

:)ensen.
__________________
Those who claim to be making history are often the same ones repeating it.
  Reply With Quote
Old 27th September 2003, 04:21 PM   #3
sam9 is offline sam9  United States
diyAudio Member
 
sam9's Avatar
 
Join Date: Jun 2002
Location: Left Coast
I don't know about Circuit Maker but my experience with other SPICE engines suggests that:

A- If the subcircuit associated with the the symbol is a generic opamp, just changing the label on it "probably" does not alter the simulation.

B- However, that is only "probably". If the the software has a subcircuit available and associated with the lable, then by changing the lable you may be invoking the other subcircuit.

The core thing you should check in the documentation is how does Circuit Maker associate what you see as symbols on the screen to specific subcircuits. Different software does this in different ways ranging from simple and easy to serious mystery and aggravation.
  Reply With Quote
Old 29th September 2003, 07:13 AM   #4
ppl is offline ppl  United States
diyAudio Member
 
ppl's Avatar
 
Join Date: Apr 2001
Location: Seattle, WA U.S.A.
Every time i have done this it has not allowed a valid simulation getting some error part not found. Had to reinstall this program one so as to get an accurate lab. so ya download a spice model and hope CM reconises the file. Another porblem i have had is with Or cad hijacking all other circuit and pcb files evean when i perset what defaults i wanted. Additionaly or cad captures unrelated files as its own so you can evean open it with the proper program after you assign it to open with..... Always open this type of ile with...... Still to no avail......
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 quick questions about PG Ti amps valterdaw Car Audio 6 15th July 2007 02:51 AM
Quick quick question ! guitvinny Pass Labs 6 7th February 2007 04:20 PM
Quick Question Staticjeep Car Audio 15 8th December 2006 08:13 PM
Quick X-over question DerekB1 Multi-Way 1 17th January 2005 07:29 PM


New To Site? Need Help?

All times are GMT. The time now is 08:45 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2