hifonics VIII zues and gemeni - diyAudio
Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th April 2009, 02:04 PM   #1
diyAudio Member
 
Join Date: Apr 2009
Default hifonics VIII zues and gemeni

hey guys ..i am very new to this..im trying to repair my hifonics collection that i own..first off i have two gemini series 8 amps..both will not power up or even go into protect..i was wondering if anybody new a good place to start looking for what might be the cause..i was wondering if maybe the thermal overloads might be bad..and if anybody new what these were called and how to check them.. with power going into the amp..i get 10 volts on one side of the thermal piece"not really sure what it is called" or the resistance of it ..any info would be greatly appriciatted.. if anybody could possibly post a pick of the inside of the amp with a pointer to what may cause this or a good place to start that would be awesome..

thanks tony c
  Reply With Quote
Old 9th April 2009, 01:42 AM   #2
diyAudio Member
 
Join Date: Apr 2009
hey guys don't all jump at once..i see alot of views but no replies... i know that there is somewere to start..i can post a pic of the board if you want....i really want to learn this kill..i want to resurect my old troopers,and listen to them again..please please help me guys.. if anybody lives in the rhode island area i would be willing to trade my plumbing and heating and hvac skills ..no bs..i trade what i am liscensed for for what you learned in school how to do..i am that serious..i will not give up on ya..i will do what ever you ask..just give me a few pointers..a starting point..just give this dog a bone..

tony
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sub for Gen VII HiFonics Morts Car Audio 0 26th May 2009 04:29 PM
hifonics viii bridged mono? rca q... marko Car Audio 4 27th February 2009 05:10 PM
hifonics viii remote turn on issues.... marko Car Audio 2 26th February 2009 04:50 PM
Hifonics Boltar VIII Problem vypr Car Audio 22 19th February 2008 03:46 AM
gen VIII collosus caseking Car Audio 7 9th November 2006 08:43 PM


New To Site? Need Help?

All times are GMT. The time now is 06:54 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2