Help restoring an old power amp? - diyAudio
Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th August 2008, 09:13 PM   #1
diyAudio Member
 
Join Date: Sep 2004
Location: North Alabama
Default Help restoring an old power amp?

Hey all...

I've recently been given a 24yr old Audire Forte power amp with a damaged right channel.. Being an electrical engineer I'm interested in repairing it myself.. I've attached a few photos, but have a few questions:

1) I'm replacing the power output transistors (MJ15022's and MJ15023's) with new ones ... 12 new power transistors (3 push, 3 pull per channel x 2 channels) are on their way, but I doubt they will be from the same factory batches ... How critical is this? (They are BJT's not MOSFETs)

2) I would really like to 'clean' the unit both physically and audibly..

2a) All of the capacitors LOOK great ... no signs of stress at all.. But they're all 24+yrs old, also.. So how can I tell what passive device(s) need replacing? (btw, I do NOT have access to a schematic, though given enough time and effort I could probably create one, but that's not high on my interest list right now)

2b) What are the best ways to *physically* clean the unit? Mostly dust buildup. Thankfully, I see very little rusting... I'm looking to clean components, metals, switches, binding posts, etc... I would prefer to NOT de-solder and re-solder everything (complete "rebuild")... just clean it "as-is" and leave existing solder-joints in place.

3) Any additional help, pointers, suggestions, etc. would be GREATLY appreciated!


thanks all,
..dane
Attached Images
File Type: jpg before (1)_sm.jpg (25.4 KB, 170 views)
  Reply With Quote
Old 14th August 2008, 10:46 PM   #2
diyAudio Member
 
Join Date: Sep 2004
Location: North Alabama
Don't know how to post multiple images to a single post, but here's another shot...
Attached Images
File Type: jpg before (2)_sm.jpg (40.1 KB, 166 views)
  Reply With Quote
Old 15th August 2008, 11:13 AM   #3
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
It looks like a well assembled dual monoblock.
Separate transformer and PSU to each channel.

Take it apart mechanically and physically clean all the components.
You can wash the PCBs, but dry them thoroughly before reassembly.

Read off the data on all the electrolytics caps. Find if all/some are available in same values, voltage rating AND with the same pin pitch.
At this age and probably having been in storage for a while, it's probably best to consider replacing all the electrolytics.
Has it got gold tolerance (5%) resistors? These are probably carbon, or your luck might be in and it's fitted with brown tolerance (1%) metal film.

Measure/test the bias current in the good side.
Make up a jig to test/measure your new BJTs.

Now measure your BJTs at the same operational current. Select matching sets of 3 for close Vbe values at that current. From your two sets of 6 you should easily get two sets of 3. If you are lucky then you may get four sets of 3 with good matches. If you are struggling, then keep the good channel as is.
__________________
regards Andrew T.
  Reply With Quote
Old 15th August 2008, 12:25 PM   #4
timpert is offline timpert  Netherlands
diyAudio Member
 
Join Date: Nov 2004
Location: Netherlands
I have once had a similar job on hand, an amplifier that above all desperately needed cleaning. It had a nice, warm blanket of dust on all PCBs and that was what killed it. Only after sorting that, looking into further details was worth the effort.

I took out the PCB's, went to the bathroom and gave them a good blast with the showerhead to clean off all dust and dried up dog drool. After that, I rinsed them with demineralised water. A blow dry with the hairdryer on a low temp setting completed the operation. The boards looked like new again. Mind however that relays and pots might not stand this treatment, so you'll want to unsolder them first. All other components have no issue with washing like this.

No need to repeat Andrew's recommendations, but if you're in a hurry (or impatient, as I often am) then at least take out the big filter caps and check them for leakage, as these are usually the fastest aging components in your amp. If these check out OK, chances are good that the rest of the electrolytics are also good. Replacing the electrolytics by modern ones will definitely clean up the sound.
  Reply With Quote
Old 15th August 2008, 12:36 PM   #5
Mooly is online now Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
You would be surprised. Have washed whole TV chassis in the past (many many times at work), just taking care not to get water in the tuner or IF coils. Foam cleaner + old brush and then rinse. The mankiest looking stuff comes up like new, don't forget the print side as well
Dry completly before powering up, an oven on 60 degrees C is good.
  Reply With Quote
Old 15th August 2008, 10:06 PM   #6
diyAudio Member
 
Join Date: Sep 2004
Location: North Alabama
Wow guys -- thanks for all those suggestions! I will get to cleaning it first and foremost very soon..

In the mean time, does anybody know where I can lay my fingers on some schematics?

..dane
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tip-Restoring Vintage Pot LinuksGuru Tubes / Valves 1 11th February 2009 03:08 AM
Restoring Veneer richie00boy Everything Else 30 26th March 2007 03:38 PM
restoring old clock ericpeters Digital Source 3 29th June 2004 09:58 PM
help with restoring amp skyraider Tubes / Valves 10 8th May 2004 04:35 AM


New To Site? Need Help?

All times are GMT. The time now is 08:00 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2