What's the "right way" to get Logitech Z680s running on 230v 50hz mains? - diyAudio
Go Back   Home > Forums > Design & Build > Parts

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th December 2007, 11:59 PM   #1
xaphod is offline xaphod  Switzerland
diyAudio Member
 
Join Date: Dec 2007
Question What's the "right way" to get Logitech Z680s running on 230v 50hz mains?

Welp, i've just moved to Switzerland and taken my Logitech Z680 with me. I've tried plugging it into a step-down trasnformer but there's a noise coming from the sub that's really annoying. It sounds like the internal transformer of the sub itself is making the noise, as opposed to coming out of the sub's speaker but i can't tell. No noise is coming through the satellites. I highly doubt this is a ground-loop issue b/c there's no ground prong anywhere in this system

Okay so here are my options, please add to this list if possible...
1. Buy a bigger more powerful step-down. I'm eyeing this 1500W toroidal step-down: 1500W toroidal stepdown. This has virtually zero magnetic field and may produce "cleaner" AC than the crappy 500W E-I form step-down i'm using right now. For all I know my current 500W step-down is overloaded and is thus introducing sinusoidal distortion...

2. Buy some sort of "power conditioner" and plug it in behind the step-down. Belkin PF series products are the expensive examples. PS audio's "Humbuster" product has been dissembled elsewhere on this forum.. might get some help producing a diode bridge thinger to get rid of DC saturation problems... but i'm not sure that this is the issue

3. Mod the Z680 sub unit: replace the power-transformer inside with one that's capable of taking 230V 50hz mains. Is this possible? Is this ridiculous unless you know a ton about electronics? Is the 50hz thing a deadend: is the Z680 designed to eliminate 60hz harmonic distortion and therefore is ALWAYS going to have a hum if the mains is 50hz? No clue. You tell me

Anyways. Losing lots of sleep over this. I don't know how to diagnose this problem and find out what it is . All help much appreciated!
  Reply With Quote
Old 11th December 2007, 06:44 AM   #2
Nordic is offline Nordic  South Africa
diyAudio Member
 
Nordic's Avatar
 
Join Date: Sep 2005
You can normally run a 60Hz tranny 50Hz but need to derate the output by about 10%...

I think your last option is the best... find out what the secondary voltages in the transformer is and get a similar one with primaries suited to your new mains....
  Reply With Quote
Old 11th December 2007, 07:52 AM   #3
xaphod is offline xaphod  Switzerland
diyAudio Member
 
Join Date: Dec 2007
Okay, cool. I have a multimeter and a limited understanding of electronics. Hopefully after I figure out how to get into the sub (there's a thread I saw on this somewhere I think on neoseeker?) will the transformer be marked? Or will i have to measure, and if so, do I have to do so while the tranny is under load?
  Reply With Quote
Old 11th December 2007, 11:34 AM   #4
diyAudio Member
 
Join Date: May 2002
Location: Switzerland
If this system was ever available on the Swiss market you might ring/mail them and try to order an original replacement tranny for 230V/50 Hz.

Regards

Charles
  Reply With Quote
Old 11th December 2007, 10:55 PM   #5
xaphod is offline xaphod  Switzerland
diyAudio Member
 
Join Date: Dec 2007
Wahoo! After much smashing about, I managed to solve the problem: I opened it right up and determined that it was indeed the transformer inside the sub that was making the noise. (It was a toroid). I put foam underneath it to stop it vibrating agains tthe wood of the sub and that fixed the problem! (well you can still hear it a tiny bit but it's MUCH better)

WOOHOO!

btw, I posted pics:
here you can see the inside of the z680 with the sub speaker removed. The toroid power transformer is at the bottom right of the photo. No, you cannot get through from the back!

http://www.fuzzymunchkin.com/tdot/ga..._itemId=132367

here is a schematic copied from the front of the power transformer (toroid) in case you want to change it or something... (i was thinking of putting a new one in that did 230v mains but now i don't need to since hum is gone)

http://www.fuzzymunchkin.com/tdot/ga..._itemId=132364


I'm a happy guy now. 300 is playing...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Jarrah" up and running... Andy G Multi-Way 7 27th June 2008 09:59 AM
cheap (230v 50hz) 160va 25+25 tranny on ebay guitar_joe Swap Meet 0 24th November 2007 11:53 PM
from 120V 50hz to 230v 50hz? testarossa2k Power Supplies 16 13th March 2007 02:32 PM
Looking for 230V >1KVA variac and 230V-230V mains isolation transformer offers Eva Swap Meet 1 28th July 2005 04:00 PM
8" Logitech woofer kderedwolf Swap Meet 0 9th May 2005 10:11 PM


New To Site? Need Help?

All times are GMT. The time now is 10:48 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2