Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Parts Where to get, and how to make the best bits. PCB's, caps, transformers, etc.

Oscilloscope Channel 1 problem on BK Precision model 2120
Oscilloscope Channel 1 problem on BK Precision model 2120
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th October 2007, 06:44 PM   #1
albertho is offline albertho
diyAudio Member
 
Join Date: Jun 2002
Location: Calgary, Alberta, Canada
Default Oscilloscope Channel 1 problem on BK Precision model 2120

This 2nd handed oscilloscope's channel 2 is in function but the channel 1 found no reaction to signal input.
The channel 1 can shows the beam line and can be positioned up and down.
Is there any link I can download the services manual or schematic?
Or could anyone give me some guidance to repair the fault channel.
Thanks very much in advance.
__________________
  Reply With Quote
Old 20th October 2007, 10:21 PM   #2
unclejed613 is offline unclejed613  United States
diyAudio Member
 
unclejed613's Avatar
 
Join Date: Dec 2006
most common problem with scope inputs is either an open resistor in the attenuator switch, or a blown diffamp transistor. the input amp of an o-scope is very much like in an audio amp, a diff pair with a current source. the diff amp feeds symmetrical VAS stages all the way to the deflection plates. between the input and diff amp, you have a stepped attenuator. if your trace can't be centered on the screen, suspect the amp section. if you can center the trace, suspect the attenuator.
__________________
Vintage Audio and Pro-Audio repair ampz(removethis)@sohonet.net
spammer trap: spammers must die
  Reply With Quote
Old 24th January 2017, 04:33 PM   #3
JMscope is offline JMscope
diyAudio Member
 
Join Date: Jan 2017
Default BK precision 1477 auto sweep

I have an old BK 1477 scope. Most functions seem to work okay, but the auto-sweep does not trigger any horizontal trace. If I connect a signal, I can trigger on it but the "auto" trigger does not function. Can anyone give me a hint on repair of this issue? Thanks.
  Reply With Quote

Reply


Oscilloscope Channel 1 problem on BK Precision model 2120Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oscilloscope BK precision 1477 Rafael L Analog Line Level 0 13th June 2009 09:15 PM
Problem w/ Sonance 2120...where can i find schematics? turbo_slug Solid State 0 23rd May 2008 09:04 PM
Kikusui COS6100M 100Mhz 5 Channel Oscilloscope JoshK Swap Meet 0 13th September 2006 07:59 PM
20MHZ Dual Channel Oscilloscope and Staco 1.4kva Variac for Sale krikor111 Swap Meet 2 18th December 2004 08:56 PM
HOW to use a Heathkit Model 10-18 oscilloscope Dusk Solid State 7 14th October 2004 10:00 AM


New To Site? Need Help?

All times are GMT. The time now is 05:33 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki