Advice on a new pa system - Page 2 - diyAudio
Go Back   Home > Forums > Live Sound > PA Systems
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PA Systems A forum for discussion of all parts of a sound reinforcement or DJ system: loudspeakers, mixers (desks) etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd June 2009, 11:00 AM   #11
diyAudio Moderator Emeritus
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Rotherham, England
As others have pointed out, the mixer is the heart of the matter here. I'd look at something like the Soundcraft EPM8, then see if you can pick up something like the JBL active Eons as speakers, they go S/H for silly money and are very robust and if something does go wrong, easily servicable, something you can't say for some of the more MI type products.
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 24th June 2009, 11:50 PM   #12
diyAudio Member
 
Join Date: May 2009
Well, I could live with a schematic. They don't sell these anymore, with good reason.
  Reply With Quote
Old 4th August 2009, 03:00 PM   #13
diyAudio Member
 
Join Date: Aug 2009
Did anyone manage to come up with a schematic? I have a PMH880S which is popping components and I really dont want to lose this mixer.

So, first prize of a Snickers bar to the one to come up with a link to the schematic !
  Reply With Quote
Old 12th September 2016, 03:22 PM   #14
diyAudio Member
 
Join Date: May 2011
Default Fix the GAIN CLIP problem on Behringer PMH880S Mixer

Does anyone have a link to the Behringer Fix Standup Jackson posted a few years ago for the gain clip problem on the PHM880S Mixer?

Over the last 8 years I have had no issues but am now experiencing clipping on a few channels of the PMH880S. Is the problem just a matter cleaning of the pots? Do the Hi-Z inputs on each channel route the signal through shorting pins on the 1/4" jacks? If so this may be the clipping issue. Any help is appreciated.

Thanks, Bob
  Reply With Quote
Old 14th September 2016, 09:49 PM   #15
diyAudio Member
 
Join Date: May 2011
Hi Enzo,

Thanks for the suggestions and links. I downloaded the schematic for the PMH880S and also looked at the PMP1280. I noticed a difference in the feedback (gain) resistors in the 1st stage in the 880S compared to the PMP1280. It's a 330K vs 100K. The PMH gain may have been a bit too much and on the later models PMP they may have decided to lower it. Although lowering these values to the 100ks may not fix my issue, it was just an observation. Also it's seems odd they decided to place the tone stack ahead of the volume control. Although I am more familiar with guitar amps than PAs.

I didn't find the 880S too difficult, but it wasn't completely disassembled.
Here's what I did:
- removed the 8 front and 7 larger rear panel screws
- pulled the chassis partially out from the rear of the plastic shell, then removed the 8 smaller rear panel screws
This allowed me to remove the front panel and inspect the 4700uF caps.

For now it wasn't required to completely disassemble it down to the power supply to test/replace FETS, but this may be the difficult part you mentioned.

I appreciate your reply and will use the forum rather than PMs. I'll try your suggestions, and let you know the results.

Thanks and best regards,
Bob
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chip Amp system - need some advice rochmndx Chip Amps 2 12th February 2008 12:50 AM
Advice on 2 way system MellowTone Multi-Way 7 23rd June 2006 02:21 PM
Computer system -need advice BMD Multi-Way 1 5th March 2006 12:36 PM
Building a new HT system, need advice Mr Pookie Multi-Way 4 11th January 2005 08:21 AM
Advice on upgrading my car system. Mendis Solid State 3 14th February 2003 11:27 PM


New To Site? Need Help?

All times are GMT. The time now is 12:39 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
Copyright 1999-2016 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki