Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

PA Systems A forum for discussion of all parts of a sound reinforcement or DJ system: loudspeakers, mixers (desks) etc.

Midas 3000 legend
Midas 3000 legend
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd January 2018, 04:36 PM   #1
angelothewolf is offline angelothewolf  Argentina
diyAudio Member
 
Join Date: Jun 2010
Location: brazil
Default Midas 3000 legend

Hi Im desperately looking for the Midas 3000 legend service manual, already contact musictribe group and they dont want to send me this info not even buying it. Can some body help me??

cheers!
  Reply With Quote
Old 25th January 2018, 11:02 PM   #2
turk 182 is offline turk 182  Canada
diyAudio Member
 
Join Date: Oct 2012
that info is going to be hard to come by without the right connections.
what sort of a problem are you having that you need service info for?
if you don't get any help here i'd consider posting on a Pro Sound forum.
  Reply With Quote
Old 25th January 2018, 11:55 PM   #3
angelothewolf is offline angelothewolf  Argentina
diyAudio Member
 
Join Date: Jun 2010
Location: brazil
Quote:
Originally Posted by turk 182 View Post
that info is going to be hard to come by without the right connections.
what sort of a problem are you having that you need service info for?
if you don't get any help here i'd consider posting on a Pro Sound forum.
Its been hard to find, I contact MusicGroup but I think there are only robots in that firm.
Im refurbishing the console, she's in great shape now we cleaned everything, I got rid of most of the issues by just taking apart the entire console and put it back together cleaning all ribbon conectors.
Now I have like five of the 48 preamps with almost same problems, ones are hiss crackling noises and no hearoom, and others are totaly dead. the last issue is the left master output . I could trace the problem to the post fader master output opamp stages but is like a complex SMD PCB and the service info could save me a lo of time... any ideas??
  Reply With Quote
Old 26th January 2018, 12:28 AM   #4
turk 182 is offline turk 182  Canada
diyAudio Member
 
Join Date: Oct 2012
other than confirming supply line voltages to op amps are correct and verifying that interstage coupling caps are not leaky, no nothing specific.
if the right master out is working it could be used to make comparison readings to aid in troubleshooting.
don't neglect inspecting things with a magnifying glass it may reveal cracked/ faulty solder joints.
i have made a few inquiries with other techs to see if i can help find the info your looking for. if anything comes of it i'll certainly let you know.

Last edited by turk 182; 26th January 2018 at 12:32 AM.
  Reply With Quote
Old 26th January 2018, 09:20 AM   #5
angelothewolf is offline angelothewolf  Argentina
diyAudio Member
 
Join Date: Jun 2010
Location: brazil
Quote:
Originally Posted by turk 182 View Post
other than confirming supply line voltages to op amps are correct and verifying that interstage coupling caps are not leaky, no nothing specific.
if the right master out is working it could be used to make comparison readings to aid in troubleshooting.
don't neglect inspecting things with a magnifying glass it may reveal cracked/ faulty solder joints.
i have made a few inquiries with other techs to see if i can help find the info your looking for. if anything comes of it i'll certainly let you know.
I really appreciate that! Thank you!
Sure I can trace the problems without schems but itís really time consuming in this particular console. Iíll be waiting for news thank you!
  Reply With Quote
Old 29th January 2018, 11:28 AM   #6
turk 182 is offline turk 182  Canada
diyAudio Member
 
Join Date: Oct 2012
well getting the schematics/service info on this is going to be a "tour de force" it almost seems like there is an active campaign to let the Legend console "embarrassment" die.

everyone i've spoken to seem to have had bad experiences with the Legend series and are quick to recommend replacing it.
  Reply With Quote
Old 29th January 2018, 03:44 PM   #7
angelothewolf is offline angelothewolf  Argentina
diyAudio Member
 
Join Date: Jun 2010
Location: brazil
Quote:
Originally Posted by turk 182 View Post
well getting the schematics/service info on this is going to be a "tour de force" it almost seems like there is an active campaign to let the Legend console "embarrassment" die.

everyone i've spoken to seem to have had bad experiences with the Legend series and are quick to recommend replacing it.
Well thats bad news. despite the common problems Iīve found on this board I didn't find nothing "embarrassing" about it at all. Thanks for the help anyway!
  Reply With Quote
Old 29th January 2018, 04:06 PM   #8
turk 182 is offline turk 182  Canada
diyAudio Member
 
Join Date: Oct 2012
it was an embarrassment to Midas from a durability/quality standpoint.

good sounding console just can't the "bumps" of touring.
  Reply With Quote
Old 7th February 2018, 04:09 AM   #9
Tajzmaj is offline Tajzmaj  Slovenia
diyAudio Member
 
Join Date: Mar 2011
Location: Ljubljana
Hi,
I have same desk and I've rebuilt mine few years ago. Probably you will find many bad electrolytic caps. Most are 100uF/25V. If you have completely dead preamps there are 2 10E smd resistors in power supply lines for each preamp. Those fail quite often.
Most problems with Legend are caused by bad ribbon cables. Actually connectors are crimped to cabled and those joints are prone to fail. It's causing things like dead channels, losing aux sends, even losing master outputs. If you like the desk I suggest you replacing those with something soldered together. I'm actually in the process right now.
Also I have complete schematics. It's too big to upload it here and it might be forbidden to make it public by forum rules, I'm not sure. P.M me and it's yours.
I've solved quite some problems with my desk and if you have any additional questions I might be able to help.

Cheers, Taj
  Reply With Quote
Old 7th February 2018, 04:18 AM   #10
Tajzmaj is offline Tajzmaj  Slovenia
diyAudio Member
 
Join Date: Mar 2011
Location: Ljubljana
p.s.

Legend is really fine sounding desk while it's working. Don't give up just be prepared to invest some ''love''
  Reply With Quote

Reply


Midas 3000 legendHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting a Midas Venice 320 drabara PA Systems 3 22nd July 2016 10:42 PM
Midas Touch phono cart. isolator Doctorcilantro Swap Meet 0 6th December 2010 03:48 AM
bora's legend 8 legend 4 east electronics Solid State 0 8th March 2007 01:25 PM
Midas Tube Dampers - 1pr. transducer Swap Meet 0 9th October 2002 04:19 PM


New To Site? Need Help?

All times are GMT. The time now is 03:23 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki