Alesis Quadraverb LCD repair - diyAudio
Go Back   Home > Forums > Live Sound > PA Systems

PA Systems A forum for discussion of all parts of a sound reinforcement or DJ system: loudspeakers, mixers (desks) etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd April 2013, 07:27 PM   #1
diyAudio Member
 
Join Date: Apr 2013
Default Alesis Quadraverb LCD repair

I have an older Alesis QuadraVerb that the LCD has stopped functioning. The unit is close to 15 years old.
Is it worth fixing, and if so, is there anybody out there who can fix it?
  Reply With Quote
Old 22nd April 2013, 11:28 PM   #2
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
I have one here in my shop, with dead audio outs. I could probably fix it, but since I can find them used and already working all over for under $50, it would be a waste of time... for me anyway.

I have a minimum bench of $45 for stuff like that, and more like $60 labor for the bill. I don't offhand know anyone selling old Alesis displays, but even if I take the working display from my dead unit, I;d still have to charge something for it - $25 comes to mind. SO now the repair is looking like $70-90 range. SO at that point, a used one for $49 sounds like the option.

No, I don't like throwing things away either, but that includes money.

That assumes the display is bad and needs replacing. Have you shone a bright light at it to see if the LCD is working and only the backlight is dead? Does it light up but blank? Or is it dark? Or perhaps the display itself is OK and the drive circuits are toast.

COnsider also that that is really a pretty old unit in terms of technology. You can find some New Behringer unit that will run rings around it for not a lot of money.

These are just my opinions, others may disagree.
  Reply With Quote
Old 23rd April 2013, 01:30 AM   #3
diyAudio Member
 
Join Date: Apr 2013
Enzo,
Thanks for getting back so soon. The unit is actually from 1992! The LCD lights up, but is blank. And even though it shows input, there is no "wet" sound coming out. I can't even change any parameters because there is no readout.
Yes, I will most likely chuck it. However, I do remember that the power supply for this unit was in big demand, and that is one of the reasons this effect device was becoming extinct.
I still have both PS and rack mount effect and the unit powers up fine.
I am going to throw the whole thing away, but if you're interested in the PS I can send it to you for a nominal fee.
I'll hold on to it for a while.
Dennis
  Reply With Quote
Old 23rd April 2013, 05:18 AM   #4
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
Thanks, but I have one - came with the dead unit.

If they are in demand, sell the thing as is for parts on ebay. SOmeone would buy it just for the included power supply.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alesis RA-100 Repair Kamuy Solid State 45 17th July 2013 02:40 PM
Schematic for Alesis RA-100... Ha! Alesis doesn't have it!! crispycircuit Solid State 0 22nd February 2010 09:16 PM
Alesis LCD goodlife Parts 1 24th September 2005 07:24 AM


New To Site? Need Help?

All times are GMT. The time now is 12:17 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2