Go Back   Home > Forums > Live Sound > PA Systems

PA Systems A forum for discussion of all parts of a sound reinforcement or DJ system: loudspeakers, mixers (desks) etc.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th September 2010, 06:40 PM   #1
ewhiz is offline ewhiz  United States
diyAudio Member
 
Join Date: Sep 2010
Default Testing PA Amplification Outputs

When testing an amplifier that has a 8 ohm, 25v, & 70v output, should I be able to read either 25V AC to gnd. or 70v AC to gnd. using a multi-meter with no speakers attached? I am only reading 1-3 volts AC at the 25V pin and 3-7 volts at the 70v pin. Do the speakers with matching transformers have to be connected to correctly test this voltage?
  Reply With Quote
Old 28th September 2010, 07:40 PM   #2
diyAudio Member
 
firechief's Avatar
 
Join Date: Sep 2008
Location: Near Seattle Wa
The AC voltage on the output of any amp will depend on where the volume is set. Amps with these 70V outputs are usually used for long runs of speaker wire and losts of small speakers like in a office space. Its not a good idea to run the amp with no speakers on it. You could try a small speaker o'n the 8 ohm taps and measure the AC accross the speaker. The different outputs are probally just different taps on the output transformer so as long as you have some kind of load on one set of taps you wont break anything.
Is this a tube amp? What else can you tell us about it?
  Reply With Quote
Old 28th September 2010, 07:49 PM   #3
llwhtt is online now llwhtt  United States
diyAudio Member
 
Join Date: Jun 2008
The 25V tap is approx. 3 Ohms, the 70V tap is approx. 24.5 Ohms. As firechief stated they are usually used with long runs and many speakers each with their own transformer mounted on the speaker.

Craig
  Reply With Quote
Old 29th September 2010, 05:41 PM   #4
ewhiz is offline ewhiz  United States
diyAudio Member
 
Join Date: Sep 2010
This is a solid state amp.

http://archives.telex.com/archives/U...0-6A%20EDS.pdf

I replaced both output transistors and several (6) signal diodes. The amp works perfect now...
However, I was trying to determine why it failed. This amp is being used in my church to power an 8 ohm speaker in the vestibule. The other speaker (70v) is located at the far end of the church in a room where they count the tithes. The end result being, the guys can hear the sermon while working.

While performing tests on the amp, I found that the speaker on the far end (70v) has no attenuator attached. It's just a plain 8 ohm speaker. No wonder the amp eventually failed! I believe once I attach a matching transformer to this 70v speaker, the impedance should match and the amplifier will receive no further damage.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nakamichi PA-7 & PA-5 Bias Setting? sourceoneaudio Solid State 6 8th March 2012 12:37 PM
Vintage Peavey PA-120 Transistor PA amp ElectricMan Swap Meet 2 26th May 2010 05:22 PM
Nakamichi PA-7 and PA-5 amps Redwingnine Pass Labs 11 30th April 2010 09:27 PM
Amplification for pro woofer testing Village Plank Multi-Way 3 22nd July 2009 02:10 PM
Balanced outputs used as inverting & Non-inverting preamplier outputs gni Solid State 4 19th September 2008 03:25 AM


New To Site? Need Help?

All times are GMT. The time now is 02:27 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2