Need help with a BSS Digital crossover and distortion on unbalanced analog - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th November 2006, 09:39 PM   #1
Ken L is offline Ken L  United States
diyAudio Member
 
Join Date: Sep 2002
Location: deep south
Default Need help with a BSS Digital crossover and distortion on unbalanced analog

Am using a BSS FDS366 Digital crossover - triamping

has been working really well - no problems on balanced out to amps.

When using a pair of Wright mono 8's 300B tube amps - no problems.

When I put a pair of Bottlehead paraglows in the system - I get distorted sound - I mean distorted -almost like fully blown speakers. This has also happened with other bottlehead and home brew amps.

What's going on here?

What solutions do I have other than putting several hundred dollars worth of transformers on the inputs?

The wrights sound fine and don't have balanced inputs -

Guidance needed _big grin_

Thanks

Ken L
__________________
No longer powered by Linux - not enough apps and cross platform integration - but maybe one day
  Reply With Quote
Old 8th November 2006, 11:08 PM   #2
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
So you bought an Omnidrive in the end then!

Is it only with valve preamps that you have that problem? Perhaps some sort of impedance mismatch, or maybe too much DC on the outputs?
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 8th November 2006, 11:33 PM   #3
Ken L is offline Ken L  United States
diyAudio Member
 
Join Date: Sep 2002
Location: deep south
[
Quote:
Originally posted by pinkmouse
So you bought an Omnidrive in the end then!
Yep. Picked up a used one. It has worked well and turned out to be a good decision - I've had it a while now.
Quote:
Originally posted by pinkmouse

Is it only with valve preamps that you have that problem? Perhaps some sort of impedance mismatch, or maybe too much DC on the outputs?
Only with valve kit or homebrew.

I believe it is probably related to DC on the imputs -

One visitor had a pair of one to one transformers - put them in the line between the BSS and the inputs of the Bottlehead valve amp and that particular homebrew then sounded fine where before the same distortion had been there. But he took the transformers with him when he went home

However, the Wright Mono 8's (straight production 300B valve amps with no mods) sound fine without transformers.

I had a friend change the impedance to 100K (the same as the Wright's) and put some DC blocking caps on the inputs ala the Wrights - but the current bottlehead amps still are making a really good bit of distortion even with those changes. They sound fine, really good actually when just used with a preamp and amp, and not hooked up to the BSS.

What's going on with these Digital crossovers? A great sounding homebrew amp belonging to another friend did a similar thing with a DEQX.
__________________
No longer powered by Linux - not enough apps and cross platform integration - but maybe one day
  Reply With Quote
Old 9th November 2006, 08:09 AM   #4
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
I'm now confused. Is the problem with pre amps or power amps?
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 9th November 2006, 01:14 PM   #5
Ken L is offline Ken L  United States
diyAudio Member
 
Join Date: Sep 2002
Location: deep south
Quote:
Originally posted by pinkmouse
I'm now confused. Is the problem with pre amps or power amps?
No pre in the system - am controlling volume with settings on BSS unit and PC software.

Am tri-amping -

the problem is only with homebrew or bottlehead tube amps.

A production tube amp - wright mono 8, works fine

all homebrew amps put in the system have had problems, but work fine when not used with the BSS

One of those, worked well with the BSS after installing a pair of 1 to 1 transformers in-line between the BSS and the amps -

I am going to put transformers in-line on one of the amps that will be permanent, but am looking for a lower cost solution to an amp that I am only planning to use while another amp is being built _grin_

The Wright 300B amps don't have transformers and replicating the impedance of the wrights doesn't solve the problem.

sorry bout that _bigger grin_
__________________
No longer powered by Linux - not enough apps and cross platform integration - but maybe one day
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Distortion figures for analog muxes eplpwr Parts 39 26th June 2013 12:08 PM
DDDAC 1543 MKII distortion on analog output zdr Digital Source 16 3rd August 2008 11:09 AM
digital or analog crossover? maghen Parts 4 10th September 2007 02:26 PM
digital or analog electro samurai Analogue Source 7 29th February 2004 05:23 PM
digital or analog? electro samurai Digital Source 0 17th February 2004 04:07 PM


New To Site? Need Help?

All times are GMT. The time now is 03:22 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2