Tannoy HPD 385 Crossover problem - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th December 2012, 07:57 AM   #1
diyAudio Member
 
Join Date: Jun 2009
Location: mountain area
Default Tannoy HPD 385 Crossover problem

Hi
I have a sound in my tweeter of HPD385 coming for sure from the crossover, cause if i lay the crossover on soft ground, no problem, but mounted on the enclosure a little kind of scratching sound comes, not always, but in some frequance range
do know how to help me, please
josef
  Reply With Quote
Old 25th December 2012, 08:04 AM   #2
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
pictures , please

whatever - opening , inspection , opening/cleaning of switches , re-flow of all solder joints , replacing all old caps
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 25th December 2012, 08:05 AM   #3
Mooly is online now Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Not sure I fully understand but I think you are saying the tweeter makes this sound when the crossover is attached back in the cabinet. And the sound comes "from the tweeter".

Could the tightening of the crossover be distorting the cabinet and consequently the distorting the tweeter frame. Try loosening the tweeter fixing screws to see if it helps isolate the problem.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 25th December 2012, 08:17 AM   #4
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
Mooly - google first how HPD is looking
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 25th December 2012, 08:43 AM   #5
Mooly is online now Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Quote:
Originally Posted by Zen Mod View Post
Mooly - google first how HPD is looking
A common problem you mean
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 25th December 2012, 08:49 AM   #6
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain


yup - common problem of generic answers

now seriously - due fact that HPD is coaxial speaker , there is no possibility that deformation in speaker baffle is causing funny noise from tweeter

OP needs to post pictures , so we can see what type of xover he is having , so we can proceed with analysis
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 25th December 2012, 09:12 AM   #7
diyAudio Member
 
Join Date: Jun 2009
Location: mountain area
Default here it is

Thanks for your quick answers
here some pictures
Attached Images
File Type: jpg P1180027.JPG (42.5 KB, 117 views)
File Type: jpg P1180028.JPG (39.6 KB, 108 views)
File Type: jpg P1180029.JPG (36.5 KB, 108 views)
File Type: jpg P1180030.JPG (32.2 KB, 106 views)
File Type: jpg P1180031.JPG (46.7 KB, 105 views)
File Type: jpg P1180033.JPG (36.3 KB, 38 views)
File Type: jpg P1180034.JPG (39.9 KB, 39 views)
  Reply With Quote
Old 25th December 2012, 09:49 AM   #8
diyAudio Member
 
Join Date: Apr 2010
Location: Brisbane
Quote:
Originally Posted by j.haindorfer View Post
Thanks for your quick answers
here some pictures
Could be one of the parts is "microphonic" probably a switch , try tapping the parts with the plastic back of a screwdriver to isolate the problem .

Cheers ,

Rens
__________________
If you measure, you know; if you guess, you don't
  Reply With Quote
Old 25th December 2012, 11:16 AM   #9
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
caps are good , mostly

so - knowing that there is enough info - google for rejuvenation of Tannoy xovers , and you'll find how to disassemble switches ; whatever , it's simple enough and you'll figure by your self how to do that

disassemble them ( taking enough pics here all the time , so you'll have enough info for proper re-assembling) , clean all metal parts with acetone or medical petrol (benzin), let them dry , put some vaseline on contacts , re-assemble them , put back on pcb and solder

while you there , clean all solder joints ( either with vacuum pump or solder wick) - work one by one ,and solder again

if wire ends are looking dark and brittle - either replace wires , or just short them by 5-10mm , blank isolation and solder again

that will solve intermittent contact problems
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa... by Mighty ZM
  Reply With Quote
Old 7th January 2013, 04:58 PM   #10
diyAudio Member
 
Join Date: Jun 2009
Location: mountain area
Default thanks its working now

hello and thanks for your good advices
I solderd all points on the crossover new, I mean I went with my soldering iron to every point and reheated, so it was melting and if there was not enough solder I put on, now its working, no cracking or strange sound
thanks
josef
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted pair Tannoy HPD 385 armandolaspatola Swap Meet 17 8th January 2013 02:41 PM
Tannoy HPD 385/385A Naidu Multi-Way 1 11th May 2011 04:23 PM
My Tannoy Monitor HPD 385 in Tannoy Berkeley enclosure is completed. lhgin Multi-Way 0 11th May 2011 03:18 PM
Tannoy HPD Surrounds rhw4 Multi-Way 5 21st July 2008 01:24 PM
Improving Tannoy HPD-385 Arden SQ? Face Multi-Way 11 23rd March 2008 06:30 PM


New To Site? Need Help?

All times are GMT. The time now is 06:38 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2