@#$ I've busted a driver, haven't I... - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th May 2012, 01:30 AM   #1
Billyo is offline Billyo  Australia
diyAudio Member
 
Join Date: Apr 2011
Location: Sydney
Default @#$ I've busted a driver, haven't I...

For reasons that I won't go into, I was carrying my tower speakers (which weigh a fair bit...) and managed to drop one of them.

Anyway, knocked a bit of paint off but didnt crush any MDF, so thats a good thing.

But afterwards it didnt quite sound right, I ran a sine sweep and at 100Hz at a fairly high volume a Monacor SPH-176 midwoofer sort of honks like Mumble out of that kids animated movie "Happy Feet".

Possibly it also honks at other frequencies - I didnt test exhaustively, since it was getting late and the wifey doesnt like test tones played at high volume when she's trying to sleep.

I gently and evenly pushed in the paper cone when it wasnt playing anything and detected a slight grating of the coil, probably against the magnets or something. I think that that grating at 100Hz is whats causing the honking sound. I guess that the shock of being dropped knocked it out of alignment so now its scratches against the sides.

It still plays ok, but I can hear that coarseness coming through on the edges of vocals constantly.

I'm up for a new driver, aren't I...? But on the off chance there is a way to repair this, then please let me know!
__________________
Epoxy Resin fixes everything!
  Reply With Quote
Old 19th May 2012, 03:26 AM   #2
DavidL is offline DavidL  United States
Banned
 
Join Date: Jul 2010
You probably broke loose the magnet/pole piece where it was glued to the front plate so that's why the voice coil is now rubbing. You might get lucky and be able to move it back into position by hand and leave it there and run a bead of glue around the edge to hold it in place. It's worth looking into and might save you paying out for a new driver.
  Reply With Quote
Old 19th May 2012, 05:11 AM   #3
Billyo is offline Billyo  Australia
diyAudio Member
 
Join Date: Apr 2011
Location: Sydney
I don't think there is any easy way to access it. The entire coil assembly is locked into a stamped metal cage with the cone at one end, the magnet at the other and no obvious way in.

I've put in an order for another two, plus the tweeter I use - just in case I need them in years to come. But rather than taking this one and throwing it in the trash, I'll attempt to disassemble it and fix it using your suggestion... after the replacement arrives though.
__________________
Epoxy Resin fixes everything!
  Reply With Quote
Old 19th May 2012, 07:18 AM   #4
diyAudio Member
 
DBMandrake's Avatar
 
Join Date: Nov 2010
Location: Glasgow, UK
If you've dropped it and the woofer frame is stamped steel you've probably bent the frame slightly, causing misalignment and rubbing of the voice coil. This can happen because the weight of the magnet hangs from the frame unsupported.

No easy fix for that I'm afraid, if that's what's happened.
__________________
- Simon
  Reply With Quote
Old 19th May 2012, 07:45 AM   #5
diyAudio Member
 
mondogenerator's Avatar
 
Join Date: Sep 2009
Location: City Of Villans
Blog Entries: 1
i have some instrument speakers which have the same problem, their frames are so weak, they can be bent by my feeble hands. I managed to sort the rubbing voicecoil by bending the frame, and you may be able to do the same. Note, however, that in my case it was a temp fix and the driver was never the same afterward. and these drivers frame was exceptionally weak, ive never seen a driver so weak. The frame was like tin sheet it was so thin and weak. Im not sure a better made frame would respond to the same 'fix'
normally id agree that epoxy fixes all, but in this case prayer may be just as effective lol
__________________
Every new piece of knowledge pushes something else out of my brain - Homer.....................Simpson

Last edited by mondogenerator; 19th May 2012 at 07:49 AM.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
busted vega. could use some help rx7speed Multi-Way 5 13th February 2008 07:27 PM
my amp is busted elmer Instruments and Amps 6 16th September 2007 08:33 PM
busted JVC turntable. help? beffie Analogue Source 5 26th April 2005 03:22 AM
is it busted? themadhippy Tubes / Valves 2 3rd October 2003 09:03 PM


New To Site? Need Help?

All times are GMT. The time now is 07:36 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2