Need help troubleshooting crossovers on my 1x15 Dietz cabs - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th December 2011, 07:22 AM   #1
diyAudio Member
 
Join Date: Dec 2011
Default Need help troubleshooting crossovers on my 1x15 Dietz cabs

Hello all! This is my first post...

I got a hold of two 1x15 Deitz pa cabs. Dietz were handbuilt cabs from the 70s built by a legendary gear dude here in Austin, TX. Well known for his mythical bass cabinets, Ray Henning I believe designed these cabs for local artists. I've also heard that he sold Stevie Ray Vaughn his famous tele that he played on for years. May be a myth, but likely true since SRV called Austin home.

Anyways... here's whats goin on:

Cab A: has 15'' Eminence (200w, 8ohm) speaker, and Peavey 22xt Tweeter. Both drivers work when plugged into normal (full range) and separately when biamped.

Cab B: Sub works. Tweeter only works when I use the Hi input on the cab, not on normal input (where both tweeter and sub should work together).

Both cabs have the same crossover- an X8 (800hz, 8 ohm). Except one is Electro Voice X8 and the other is University Sound X8 (both are exactly the same. I don't believe these are made anymore.

TWO THINGS I DON'T UNDERSTAND:

1. There is an extra component in each cab, connected to the crossover. They both consistent of a coil of wire on a spindle, two AAA battery style metallic tubes and a rectangular ceramic piece. In Cab A this component is bypassed or not connected to the crossover at all. Could this be whats causing the tweeter to not work with the sub in normal mode in Cab B???? What is this extra Component? Is it necessary?

2. The tweeters get distorted at higher volumes (but within there power handling range), during peaks in bass. If the crossovers are working shouldn't they only be sending freq's the the drivers can handle? What am I missing?

So, there you go... my first post! These cabs have some history to them and I'd hate to see 'em go to waste so... Please help if u can! Thanks in advance!
  Reply With Quote
Old 28th December 2011, 07:32 AM   #2
just another
diyAudio Moderator
 
wintermute's Avatar
 
Join Date: Aug 2003
Location: Sydney
Blog Entries: 22
Hi and welcome to diyAudio I've moved the thread to multiway since it is a multiway speaker

You might want to post a picture of the mystery crossover component. It sounds like it is some sort of coil but hard to tell from the description.

on point 2, the crossover slope is probably not steep enough, or the crossover point is too low. It could also be that the amp is clipping on the bass transients.

Tony.
__________________
Any intelligence I may appear to have is purely artificial!
Some of my photos
  Reply With Quote
Old 28th December 2011, 08:29 AM   #3
diyAudio Member
 
Join Date: Dec 2011
Default here's photos

Pic legend:
A1 is Cab A's crossover section

A2 is Cab A's extra component (disconnected)

B1 is Cab B's crossover section

B2 is is Cab B's extra component
Attached Images
File Type: jpg A1.jpg (803.2 KB, 13 views)
File Type: jpg A2.jpg (902.7 KB, 13 views)
File Type: jpg B1.jpg (784.8 KB, 12 views)
File Type: jpg B2.jpg (739.9 KB, 11 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amp to power 1x15", 4x5" & 2xTweeter brizk1d Solid State 0 27th September 2011 07:53 AM
Suggestions for Building a 1x15 Cab Thraxor Multi-Way 4 10th December 2008 11:29 PM
Tannoy 15" Reds for sale with crossover and cabs (local pickup for cabs) saletel Swap Meet 0 27th October 2006 10:01 PM
Passive Radiator system with 2x10 inch and 1x15 inch Lach O'Sullivan Multi-Way 3 13th September 2003 03:29 PM
Subwoofer, 2x12" or 1x15/18"? Matttcattt Subwoofers 71 23rd July 2003 10:37 PM


New To Site? Need Help?

All times are GMT. The time now is 07:54 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2