help mounting Radian CD - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th September 2010, 02:45 AM   #1
bvan is offline bvan  Denmark
diyAudio Member
 
Join Date: Apr 2006
Default help mounting Radian CD

Well I just took delivery of some 465PB today and find the mounting studs can only go about one turn deep into the mounting holes. This is trying all studs on all holes. Has anybody else experienced this or are mine defective somehow.

They sit fairly securely but still with a bit of wobble and not completely vertical. Seems strange they dont screw further down into the threaded holes.

Cheers
B
  Reply With Quote
Old 8th September 2010, 03:02 AM   #2
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: Milliways
Blog Entries: 4
That is strange. Not a problem at all on my old Radians.
Could they be the wrong thread pitch?
  Reply With Quote
Old 8th September 2010, 03:16 AM   #3
bvan is offline bvan  Denmark
diyAudio Member
 
Join Date: Apr 2006
Thanks for the reply.

Now I am a bit worried, time to phone the States I think.
  Reply With Quote
Old 8th September 2010, 03:26 AM   #4
diyAudio Member
 
Join Date: May 2006
Default I agree about the thread

I think they should be 1/4" bolts, If you use 5mm bolts thhey wont go in!

I have Radian 950 pb never had that problem...
__________________
That is why they make vainilla and chocolate!!
  Reply With Quote
Old 8th September 2010, 03:32 AM   #5
Pano is offline Pano  United States
diyAudio Moderator
 
Pano's Avatar
 
Join Date: Oct 2004
Location: Milliways
Blog Entries: 4
Yes, 1/4" 20 (thread pitch)
  Reply With Quote
Old 8th September 2010, 04:29 AM   #6
bvan is offline bvan  Denmark
diyAudio Member
 
Join Date: Apr 2006
It does look like 1/4 20, and its what came with the brand new drivers from usspeaker.com which is the strange thing.
  Reply With Quote
Old 9th September 2010, 02:08 AM   #7
bvan is offline bvan  Denmark
diyAudio Member
 
Join Date: Apr 2006
Radian managed to figure out the problem, luckily. They recently changed from the US system whatever its called (1/4") to metric (M6) and usspeaker.com sent me the wrong bolts. No apology from usspeaker and they wont send me the correct ones, told me to go out and buy some, the pricks.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radian PB850 - any experiences? Defo Multi-Way 46 1st April 2014 07:23 AM
Radian 5215B coaxials? BHTX Multi-Way 27 19th December 2008 08:38 AM
WTB Radian coax gabrittain Swap Meet 0 20th April 2008 03:32 PM
Anyone used Radian co-axial drivers? DrG Multi-Way 12 18th August 2004 06:20 PM
Radian 508 drivers tmd Multi-Way 1 3rd May 2002 04:22 PM


New To Site? Need Help?

All times are GMT. The time now is 07:00 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2