take a look at my fr plots and tell me what you think about that null - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th July 2008, 02:02 AM   #1
pjpoes is offline pjpoes  United States
diyAudio Member
 
Join Date: Jan 2005
Location: New York
Send a message via AIM to pjpoes
Default take a look at my fr plots and tell me what you think about that null

I've been trying different crossover values in my Focal Tower project, and I'm having trouble getting rid of this dip or null in the response. In order to take these measurements I used a mixture of spatial averaging at 1 meter and close miking of the woofer.

I'm still figuring out how to do the spatial averaging, so please ignore some of the kinks in the response. Also, I apologize for the 1/6th smoothing, the program automatically applies it when you combine two plots. The area I am concerned with is around the 3.5K mark down to around 1.5K. The response slides down, but its not the crossover point (That is around 1.8K). If you look at the response of just the tweeter, it looks somewhat tilted upward, so I think one solution will be to use a larger shunt resistor in the l-pad and a larger padding resistor, thus tilting the response down more. My second idea was a contour filter, but I don't know if I like that idea so much. Click the image to open in full size.
Oops almost forgot. Ok the Blue line was my original crossover, and the Red line was my attempt at fixing the null. As you can see it didn't help where I needed it to.

Do you think there is too much baffle step? I spent all that time making sure the baffle step was right, taking measurements, running models, and I think I over estimated the needed baffle step. The first inductor position in the woofer circuit uses a 3.2mh inductor, and I've been contemplating a smaller one of say 2.5mh or so.

The final issue, which I don't have a graph to show, is distortion. From around 100hz to 2khz its less than .3 percent THD, and above 5K its below my system residual. However, between 2 and 5K its over 1%, so I think I need to add an LCR conjugate filter. Now I know why Orca had one. It's not audible durring music, but is very audible during test tones. I'm thinking I may notice a difference with brass instruments like trumpets though after I add the LCR.
  Reply With Quote
Old 17th July 2008, 04:43 AM   #2
pjpoes is offline pjpoes  United States
diyAudio Member
 
Join Date: Jan 2005
Location: New York
Send a message via AIM to pjpoes
Click the image to open in full size.

I was messin around with some measurements of my subwoofer. Here is the response of my subwoofer spliced in with the speakers. So this is close mic on the midbass and subwoofer driver spliced into the 1 meter spatially averages response above 300hz. Port response was also spliced in. Originally the subwoofer was way too high, so I now have it measuring much flatter. Impressivly flat really. In room far field doesn't look anywhere near that good, but still isn't bad.

Just have to get that treble issue worked out. Even with the slight issue in the treble (And who knows if it will actually sound better without the dip) they sound pretty nice. Still have that amazing sound stage I noticed first time around. Imaging is really great and the realism of instruments is impressively real. Also, since I revised the crossover and brought the efficiency back up into a reasonable level I feel like dynamics are really pretty good. I still want to go forward with the bigger speaker project, but this has given me some ideas.

I did some measurements with and without foam on the baffle. I should post those, I think people would find it interesting. It did nothing good, not even anything that would be good with crossover modifications. I'm going to try some wool felt next and see. I think the problem is that you have to design the foam into the baffle, the tweeter has to be set back from the midbass the distance of the foam. I'm also wondering if this foam is more relfective than felt would be. Anyway, I would recomend against just sticking some pieces of foam on the baffle because you think it might help. It probably will hurt things quite seriously.
  Reply With Quote
Old 17th July 2008, 05:24 AM   #3
diyAudio Member
 
Join Date: Dec 2002
Location: Utah
I can't remember in which thread I read it but the jest was that a change in crossover part value at a lower frequency can effect the filter a couple of octave above. It looks like you proved this is true.

However, how do they sound. Since the ear is very sensitive in the 2-3k region I almost think that little null is in the perfect place to have one so long as it is not too much of one.
  Reply With Quote
Old 17th July 2008, 02:09 PM   #4
pjpoes is offline pjpoes  United States
diyAudio Member
 
Join Date: Jan 2005
Location: New York
Send a message via AIM to pjpoes
I think they sound very good. As I mentioned, I'm measuring overly high distortion near that null, and its audible with test tones. Last night I used a variety of sources, including some uncompressed 24/96k recordings I have on my laptop to see if I can't hear the distortion. It's hard to say if its in my head or really there, but I have this impression now like I can hear it with the upper end and harmonics of brass instruments, distorted guitar, and female vocals. Only way to tell for sure will be to modify the crossover with the LCR conjugate filter and see if it changes anything.

I'm kind of interested in building a similar two way using very different drivers. Say an Usher 7" midbass and BG planar tweeter, something so different in the driver technology approach, to start and get a better sence of what causes what.

I also have a series crossover idea floating around I want to try. I have modeled two versions that would be interesting.
  Reply With Quote
Old 17th July 2008, 02:16 PM   #5
diyAudio Member
 
Join Date: Mar 2006
Location: Bucharest
@pipoes

It's pretty hard to say something about the nature of the dip and ways to fix it whithout seing the individual driver response and/or crossover.

I usually see this due to phase mismatch between drivers (out of phase) just above the crossover frequency in a LR2-to-be crossover.

To the distorsion issue: this might just be the tweeter crossed over too low and "protesting" against the exccesive excursion.
__________________
I don't believe in audio believings.
  Reply With Quote
Old 17th July 2008, 07:16 PM   #6
pjpoes is offline pjpoes  United States
diyAudio Member
 
Join Date: Jan 2005
Location: New York
Send a message via AIM to pjpoes
My individual driver response are a bit hard to read. I have a good one for the tweeter, but the midbass was complicated to measure (I had to combine three separate sets of measurements.) I can post the model, but it doesn't look like the model, as would be expected, so I need to take new measurements using what I have since learned about the software to make them make sense. The reason why I don't think the null is a phase issue is that its outside the crossover point. The crossover point is lets say roughly 1.8khz, where as the null is like 3.5 khz. Changing the crossover point up or do didn't change that null any. Reversing phase just causes a null at the crossover point, lower down, so its not that either. moving the tweeter back (Via a ladder delay) also did nothing for it.

Any chance its an artifact caused by the baffle? As I said I didn't route the tweeter right and its recessed too much by about 1/8". I thought some acoustic foam would tell me, but the foam is 1/2" and thus too thick for this purpose. It just made things much worse over all. I've seen the same null in some of zaphs designs, so I wonder if its nothing. I mean, it seems to go away from a greater distance, though then the measurement just becomes worse in general from the rooms effects. My room is acoustically treated, but not enough to remove all room effects (4 acoustic panels won't do that).
  Reply With Quote
Old 17th July 2008, 11:27 PM   #7
diyAudio Member
 
roger_lew's Avatar
 
Join Date: Nov 2005
Location: Moscow, ID
You could try to fix your tweeter mounting by getting some 1/8" plywood and cutting rings to place under your tweeters. You can probably find small "hobby" sized pieces of void-less plywood at your local craft or hobby shop.
  Reply With Quote
Old 18th July 2008, 12:30 AM   #8
pjpoes is offline pjpoes  United States
diyAudio Member
 
Join Date: Jan 2005
Location: New York
Send a message via AIM to pjpoes
I have some luon (Is that how its spelled?) I could try I guess. I actually wanted to remake the baffles, they were test enclosures to begin with anyway. I tried to use extra gasketing tape to build it out enough, but that didn't seem to do anything, but there still was a bit of a lip. I went and remeasured, its actually not 1/8" I guess I was exaggerating a little. It was actually around 2mm or so.
  Reply With Quote
Old 18th July 2008, 12:32 AM   #9
diyAudio Member
 
Join Date: Nov 2006
Why don't you try reversing your tweeter polarity and retesting the FR response? The nulls created will give you some indication as to how closely in phase your drivers are at the crossover.

JJ

Quote:
but I have this impression now like I can hear it with the upper end and harmonics of brass instruments, distorted guitar, and female vocals
Are you using metal coned drivers (or perhaps woven fiberglass)?

JJ
  Reply With Quote
Old 18th July 2008, 01:59 AM   #10
diyAudio Member
 
roger_lew's Avatar
 
Join Date: Nov 2005
Location: Moscow, ID
Gotcha. That doesn't sound to bad.

Have you tried taking attenuation off the tweeter? I wonder if you could raise it by 3-6 dB to smooth bring up that middle portion without it sounding overly bright?

P.S.

If you like how it sounds you also might consider leaving it for the time being. You always run the risk of taking some of the magic out fiddling with it.

  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
waterfall plots bonsai171 Multi-Way 28 8th January 2014 05:24 PM
Need help with impedance curves and FR plots... fjhuerta Multi-Way 13 8th April 2006 08:57 AM
Understanding Waterfall Plots ralph-bway Multi-Way 1 24th October 2005 12:41 PM
Sensitivity vs Impedance Plots? johninCR Multi-Way 5 24th November 2004 12:40 AM
Impedance Phase Plots kelticwizard Multi-Way 13 28th February 2004 06:28 PM


New To Site? Need Help?

All times are GMT. The time now is 01:02 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2