Any Problems with Hovland Musicaps? - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th April 2008, 10:19 PM   #1
clm811 is offline clm811  United States
diyAudio Member
 
clm811's Avatar
 
Join Date: May 2002
Location: Northern California
Default Any Problems with Hovland Musicaps?

Anyone on the forum ever heard of problems with the leads attachment on Hovland Musicaps?

-Chas
  Reply With Quote
Old 30th April 2008, 05:08 AM   #2
diyAudio Member
 
jtsaudio's Avatar
 
Join Date: Dec 2007
Hi Chas!
What kind of "problems" are you referring to?

Joe
  Reply With Quote
Old 30th April 2008, 08:13 AM   #3
diyAudio Member
 
kiwi_abroad's Avatar
 
Join Date: Sep 2001
Location: Wellington, New Zealand
I had one where the lead fell off, if that's what you are referring to. Ruined the cap of course.
  Reply With Quote
Old 30th April 2008, 08:27 AM   #4
clm811 is offline clm811  United States
diyAudio Member
 
clm811's Avatar
 
Join Date: May 2002
Location: Northern California
Well,
I have a couple of Musicaps that, after mounting and then removing from test crossover boards, measure as "open" circuits.

I'm not sure how/why this occured, as I didn't subject them to rough handling; furthermore, the large Solen Fast Caps(also stranded leads) removed from the same mountings are fine. The Hovlands look fine, physically- they just don't work.

I was just wondering if anyone else has had or heard of similar problem(s)...

-Chas
  Reply With Quote
Old 1st May 2008, 05:24 AM   #5
diyAudio Member
 
jtsaudio's Avatar
 
Join Date: Dec 2007
I've had no problems with the Hovlands myself, but have heard one or two stories about problems similar to yours.
Joe
  Reply With Quote
Old 1st May 2008, 08:50 PM   #6
clm811 is offline clm811  United States
diyAudio Member
 
clm811's Avatar
 
Join Date: May 2002
Location: Northern California
I was interested in anyone else's first-hand experience, as I've read a few other anecdotal stories.

Anyway, I've returned the bad caps to the manufacturer and am awaiting replacement.

-Chas
  Reply With Quote
Old 17th May 2008, 12:05 PM   #7
clm811 is offline clm811  United States
diyAudio Member
 
clm811's Avatar
 
Join Date: May 2002
Location: Northern California
Thumbs up Replacements received

The replacements came a few days ago and these new HOVLAND caps are great. One change I noticed is the new caps have red and green leads(the old ones were clear with a colored stripe) which have a better seal.

The resolution of fine detail and clarity is distinctly better than the SOLEN and AEON caps they replace in my crossover. Used with the VIFA XT25 bells have a sharp attack with a "glow" about their ring and cymbals have a delicate shimmer that doesn't sound like white noise anymore.

I can't imagine a better tweeter cap than these!

-chas
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Hovland Musicaps 100V 5% glt Swap Meet 0 26th October 2008 12:01 AM
hovland best prices ermes Multi-Way 0 18th November 2004 10:19 AM
Auricap, Hovland or NO Cap?[Search for the Best Cap] Elso Kwak Solid State 8 16th May 2003 05:48 AM
Hovland Musicap .22uF 400V M_Anker Swap Meet 0 11th February 2002 03:09 AM


New To Site? Need Help?

All times are GMT. The time now is 03:06 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2