Celestion DL8 S2 Surround - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th March 2008, 11:42 AM   #1
diyAudio Member
 
Join Date: Mar 2006
Location: Great Yarmouth, UK
Default Celestion DL8 S2 Surround

Hi all,

I bought a pair of these speakers on ebay, and they have arrived today.

It seems I have an odd pair. One looks as though the surround has been replaced. It seems like a slighty different material, though both are rubber like and of the same design.

The problem is, the one that seems to have had its surround replaced starts to make a vibrating rattly kind of noise in the lower frequencies, lower than about 60Hz. This is at very, very little volume too.

I know it's not a lot to go on probably, but is there any chance that this is easily fixable? I don't know all that much about speaker construction. Is it likely a case of redoing the surround?


edit - I should add, if I gently place my finger on the edge of the cone, the rattling stops and all sounds fine.
  Reply With Quote
Old 14th March 2008, 12:51 PM   #2
diyAudio Member
 
Join Date: Mar 2006
Location: Great Yarmouth, UK
I have a feeling that it may be "unsafe" to use this speaker. If I push the cone outwards so that I can see more of the voice coil, I can clearly see that it's been rubbing and, as a result, the enamel has worn away

I guess I probably need to find a replacement driver, or get it repairs professionally. I don't think I am capable of rebuilding the whole thing, though if I have to buy a completely new driver I will probably give it a go, just as an experiment. It would only be thrown out anyway....

I don't suppose anyone knows where I might be able to get it repaired in the UK? I will e-mail Celestion and see if they have any replacement drivers, though I doubt they will really.
  Reply With Quote
Old 14th March 2008, 01:45 PM   #3
diyAudio Member
 
Join Date: Mar 2006
Location: Great Yarmouth, UK
Oh, I can see what it is causing this now! It has obviously been very poorly repaired in the past. One of the wires from the spade terminals to the voice coil is far too short, such that when the cone gets about half way it is stretched to like a guitar string! I guess this then pulls on the cone and causes it to become misaligned.

I supposed I could have fixed this myself by soldering a little extra wire, if it weren't for the partially shorted voice coil
  Reply With Quote
Old 14th March 2008, 03:13 PM   #4
diyAudio Member
 
Join Date: Mar 2006
Location: Great Yarmouth, UK
Well, I came to the conclusion it shouldn't do much harm to correct the short wire. I soldered an extra piece of wire so it can move freely.

The problems still remain unfortunately. I think the main culprit is, however, the surround. It is really so incredibly loose compared to the untouched woofer.

The surround is kind of strange looking. It's inverted compared to the usual kind of surround. An "innie". Don't suppose anyone knows where I could find a nice new stiff rubber surround in the UK?

I've searched google but can't seem to come up with much.

The woofer is quoted as 8", though this measurement seems to be from the edge to edge of the surround. I'm not sure if this is normal. From the cone edge to edge it is more like 6".
  Reply With Quote
Old 14th March 2008, 03:30 PM   #5
Speakerholic
diyAudio Moderator
 
Cal Weldon's Avatar
 
Join Date: Jan 2004
Location: Near Vancouver
Hi, sorry to hear about your misfortune. Can't help you with the repair but it sounds like you'll need a recone, not just a surround if the enamel is rubbed off the coil. Probably best to do both woofers at the same time.

That woofer has a pincushion frame so as far as how to measure it, who knows? It used to be that woofers were measured from center to center on the mounting holes.
__________________
Next stop: Margaritaville
Some of Cal's stuff | Cal Weldon Consulting
  Reply With Quote
Old 14th March 2008, 03:49 PM   #6
diyAudio Member
 
Join Date: Mar 2006
Location: Great Yarmouth, UK
Hi Cal,

Thanks for the reply.

Shortly after posting I found a speaker repair place very, very local to me. I just phoned and he says he may have some spare drivers and he is going to look about for me over the weekend. He seemed fairly sure he had some DL8 or DL6's, but just couldn't remember which.

If not, then a repair will cost between 25 and 35 per drive unit, apparently. I am guessing that because the voice coil enamel has been scraped away, it's going to be more like 35. I actually asked about the price of a second hand driver after this, and he said that it should be cheaper...

I will take them in Monday hopefully and see what can be done! I paid 22 for them, but then 25 postage.... wouldn't have been so bad if they were both OK!
  Reply With Quote
Old 3rd April 2008, 11:50 PM   #7
diyAudio Member
 
Join Date: Mar 2006
Location: Great Yarmouth, UK
Well, an update to finish off the thread really.

I got the driver surround re-done at previously mentioned shop. They didn't have the correct sized surround, so they had to chop a slightly larger one and rejoin. I didn't think much of it, I thought they would be able to do a reasonable job and make it quite tidy, considering they have the facilities to product drivers themselves. 25 to have it done.

It looks quite ugly. No attempt to make things neat at all really. Glue spilling over on to the cone. I guess that's not their primary concern. I'm sure they could have managed to make it neat though, if they had tried? Shame.

When in the cabinet, tapping the cone makes a completely different sound to the original. The suspension is also still looser. Though the rattling is gone, and my ears can't tell if there's any difference in sound between the two. May say a lot about my hearing abilities!

Wasn't all that happy with the end result to be honest, so I decided to look out for another set, or even just some drivers. Wasn't hopeful for just a replacement driver in good condition, but another set did indeed come up quite quickly! I won them for 17.50 and 14.50, for a total of 32. Nice lot of pictures, and they look in rather good condition indeed.

I paid 50 for this dodgy set - he refunded the 25 to attempt repair, so I didn't actually pay any extra to have that done - so that's somewhat of a result. I'll probably put the spare set in the loft for my little sister, should she ever get in to audio that much A spare driver for it might pop up one day. I doubt I could really sell them with the driver in that condition. Well, maybe I could... but I wouldn't like to. It seems... wrong.


This hobby can get quite crazy
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Celestion MD-500 and MF-500 peterdav Multi-Way 1 9th December 2010 09:29 AM
axial surround instead of radial surround Calvin Subwoofers 22 13th July 2009 06:46 PM
celestion cs-7 marijan Multi-Way 1 23rd December 2002 04:43 PM


New To Site? Need Help?

All times are GMT. The time now is 07:15 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2