crossover issue - diyAudio
Go Back   Home > Forums > Loudspeakers > Multi-Way

Multi-Way Conventional loudspeakers with crossovers

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th September 2007, 07:48 AM   #1
diyAudio Member
 
Join Date: Sep 2007
Default crossover issue

Hi guys, I'm trying to connect my crossover (Ultradrive pro DCX2496)
into an amp (EP 2500). I can't get a signal on the amp.
I have connected the XLRs from the mixer
and the signal is showing on the DCX.
The problem is my output to the amp.
Signal is illuminating on the DCX side but not on
my amp (EP2500). What initial settings am I missing ?
Is there a gain(volume) knob that I'm supposed to turn on the DCX ?
please help
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
crossover issue in first 3 way mp006ltk Multi-Way 1 2nd April 2007 05:32 PM
Can you hear the crossover point of a speaker with a well-designed crossover? 454Casull Multi-Way 11 2nd April 2004 05:48 AM


New To Site? Need Help?

All times are GMT. The time now is 05:31 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2