diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Multi-Way (http://www.diyaudio.com/forums/multi-way/)
-   -   I bought bad Mission 753's, T's and x-overs fried, worth fixing? (http://www.diyaudio.com/forums/multi-way/107658-i-bought-bad-mission-753s-ts-x-overs-fried-worth-fixing.html)

timbert 29th August 2007 03:17 AM

I bought bad Mission 753's, T's and x-overs fried, worth fixing?
 
2 Attachment(s)
This is not really a horror story to me because I bought these on Craigslist for $60, but I hooked them up and got no tweeter sound, and they just sounded bizarre and about 1/3 as loud as they should be. I unscrewed the tweeter but before I unsoldered it, I removed both crossovers and saw they were melted to the interior foam. Here's a photo of one of them. That's the horror story, and I'm not sure how an amp could do this, maybe they plugged the speaker into an ac outlet? It got so hot in there some of the solder on one corner melted and dripped down to the end of the PCB, as did much of the glue. I attached one of the tweeters to a regular amp and slowly increased the volume. I had it turned up about halfway before I heard faint music, so does that mean the tweeters are fried as well? The tweeters are the square type; other version came with round ones. I am sure the previous owner had them bi-wired or bi-amped, because the jumper bars on the banana plugs were missing.

These are Mission 753 units, serial number 530007238. The crossovers say "53-xover/B05". Are worth fixing? I have a DMM and have done limited PCB work, and I have an oscilloscope I barely know how to turn on. My other speakers are all rear-ported: Paradigm 11se Mk 3, 5se, Titan (version 1) and some little Sound Dynamics 2 ways, and I thought these front-ported Missions might be nice to compare with what I already have. There was a guy selling these woofers on ebay for $40 each, so I thought what the heck. I read on this forum that the crossovers are not "conventional" 2 way design, so I need some advice from a fellow DIY addict. Thanks in advance.
Tim

Foxx510 29th August 2007 03:57 AM

Are all the drivers measuring ok?

ashok 29th August 2007 04:19 AM

Very insensitive drivers mean they are fried. Did you check what Foxx510 asked ? All drivers showing nominal dc resistance values ?
If the woofer is OK ( normal volume ) the it could have been a badly clipped signal ( massive overdive ) or RF ( oscillations).
DC offset would burn the woofer and keep the tweeter safe if the standard series capacitor was in place.

Here the resistor appears to belong to the tweeter and that end is burnt !:eek:

However the coil at the other end also got hot ! DC after breakdown due to oscillations ? Burnt components is something but a burnt pcb like this 'really' something else !

If the drivers are gone then replacing them with the original might be expensive. I'm surprised that you say both units were similarly damaged.

planet10 29th August 2007 04:31 AM

Re: I bought bad Mission 753's, T's and x-overs fried, worth fixing?
 
Quote:

Originally posted by timbert
I'm not sure how an amp could do this
Big amp, under-powered resistor.

We started the damping foam on a set of Tangent RS4s on fire once. Driven by a Bryston 4B, John Greenbank (magaging director of Tangent) asked us to keep turning it up. Acrid smoke started billowing out of the square ports & very shortly after the woofer went quiet. Boy did it stink. Fresh woofer and we were enjoying music again in 15 minutes.

dave

timbert 29th August 2007 05:10 AM

2 Attachment(s)
My son is removing the drivers on one speaker so I can test them. Here's the other crossover, showing burnt foam and the solder that ran down to the bottom of the board in two places. Remind me again how I'm measuring te drivers with my Fluke DMM? I assume I have to clip the two leads off.

Foxx510 29th August 2007 05:18 AM

Remove at least one of the driver wires, then measure across the terminals using the ohms setting on the dmm. You are looking for around 4 - 8ohms. If it is open circuit, ie the meter does nothing then it is blown.

timbert 29th August 2007 05:41 AM

2 Attachment(s)
I popped off two drivers and they measure 3.9 ohms between the two leads, out of circuit. Ran speaker leads to them and fired up the amp and they sound like drivers would sound without a box. Yes, both crossovers were similarly burnt, here's a photo showing one of the coils that melted the plastic it was coiled around.

timbert 29th August 2007 05:43 AM

2 Attachment(s)
Here's the burned foam inside and some stuck to the resistor.

Foxx510 29th August 2007 05:49 AM

Word of warning, don't hook the tweeters up to an amp and test them with a full range signal, you might pop them. No worries with the woofers though.

timbert 29th August 2007 08:17 AM

Yes, looks like tweeters are shot at well, where do I get replacements? They have what looks like a Mission part number 53-HFLM2/. Thanks again for everyone's help.


All times are GMT. The time now is 04:46 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2