American bass protection mode - diyAudio
Go Back   Home > Forums > Member Areas > Introductions

Introductions Welcome to the DIYaudio Community. Introduce yourself here so we can get to know you better!

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th October 2013, 04:16 PM   #1
diyAudio Member
 
Join Date: Oct 2013
Location: Austin
Default American bass protection mode

I have 3 American bass amps each with their own power supply from a second battery. I had 3 Jl audio 15w3v2d4 but the foam is no good. I was in the process of switching out subs to kicker cvr subs. I hooked 2 subs up and decided to turn on the subs to see how they worked but the 2 amps that had the subs hooked up went into protection mode. No blown fuses. I have 0 gauge power and ground with extra battery. My 3rd American bass amp is not protect mode. Any help would be taken. Idk my model amps but they are all black with chrome in the middle. Only one light red or green. And my American bass stickers are coming off in the center of the amps
  Reply With Quote
Old 15th October 2013, 02:39 PM   #2
Speakerholic
diyAudio Moderator
 
Cal Weldon's Avatar
 
Join Date: Jan 2004
Location: Near Vancouver
Hi there, welcome to diyAudio. You might wish to take this over to the appropriate forum. You'll probably get a better response. Good luck with it.
__________________
Next stop: Margaritaville
Some of Cal's stuff | Cal Weldon Consulting
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
American Bass CX-1200-D mike49504 Car Audio 14 16th October 2013 03:16 PM
American Bass sq300 Jailbreak Car Audio 1 22nd August 2013 06:49 PM
Help with American Bass XD3000 RJohns777 Car Audio 4 17th March 2011 12:13 PM
American Bass CX 1200 D mike49504 Car Audio 47 18th January 2011 02:54 AM
American Bass VFL-500.1 mike49504 Car Audio 5 7th January 2011 11:07 PM


New To Site? Need Help?

All times are GMT. The time now is 04:01 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2