Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Instruments and Amps Everything that makes music, Especially including instrument amps.

Ampeg SVT-8 Pro Power Supply Help
Ampeg SVT-8 Pro Power Supply Help
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th September 2014, 04:25 AM   #1
Upionics is offline Upionics  United States
diyAudio Member
 
Join Date: Aug 2004
Location: Santa Fe, NM
Default Ampeg SVT-8 Pro Power Supply Help

I have an Ampeg SVT-8 Pro that has a weird story but basically died one day and the Fault and Limit lights stay on constantly. Preamp section tests out good and passes signal. I am somewhat sure that it is the Class D 2500 Watt power amp section that may just need to be replaced entirely.

But... I want to make sure the Power Supply is good. Testing seems fine, the rails have steady voltage and the +/- match fairly closely. Preamp tube section is getting power just fine. There are even LED's that light up.

And... here is the thing, some of the voltages don't match and I don't know enough to tell if/where the problem is or if there is a typo on the schematics.

Schematics for the power supply are attached and they were sent from Ampeg. My concern is at J2 and J3 on the second page, it specifies +/- 120V. But I am getting +/- 138V.

Then the real kicker is J7 on the second page. It specifies +/- 12 V Float and I am measuring +/- 120V!! I triple checked thinking I was crazy!

So is that just a typo on the schematics? Maybe the 138V is still in range? What else could be wrong?

I haven't gotten a quote on the power amp module yet, but I assume it isn't cheap and I would hate to blow it up without making sure the power supply checks out.

Thanks in advance!
Attached Images
File Type: png Ampeg-SVT8Pro-PS1.png (190.8 KB, 109 views)
File Type: png Ampeg-SVT8Pro-PS2.png (274.2 KB, 104 views)
File Type: png Ampeg-SVT8Pro-PS3.png (212.9 KB, 101 views)
  Reply With Quote
Old 2nd October 2015, 10:31 AM   #2
gzzdkj is offline gzzdkj
diyAudio Member
 
Join Date: Oct 2015
Default i want svt8 amp schematics

i have a worry ampeg svt8. amp part is some worry.but i hanve not schematcs for this part . could you give me svt8 power amp schematis? thank you so much.
  Reply With Quote
Old 2nd October 2015, 11:51 AM   #3
JonSnell Electronic is offline JonSnell Electronic  United Kingdom
diyAudio Member
 
JonSnell Electronic's Avatar
 
Join Date: Dec 2012
Location: The Jurassic Coast, England. GB
J2 ans J3 are about right as it will be off load. J7 is + - 12V floating at 120V or 138V.
I would check your centre point on the power stage before doing anything else. I don't have a schematic on the amp section so if you need any further information, please forward it to my email address and I will help you repair it. jon@jonsnell.co.uk
__________________
Support for Fender, Marshall and all Valve Equipment; Audio Innovations, Audiorama FU29, Quad and Leak. www.jonsnell.co.uk
  Reply With Quote
Old 2nd December 2015, 12:51 PM   #4
Ampeg is offline Ampeg
diyAudio Member
 
Join Date: Dec 2015
Default Ampeg SVT-8 Pro Bust

Looks like I have a busted power amp section as well, disconnect the power amp board and it comes out of protect. Changed a shorted FET on the power amp board, but still in protect, so looks like more going on. Pre-amp section works fine. Any schematics for the power amp section available from anyone?

All help greatly appreciated.

Mike
  Reply With Quote
Old 22nd May 2018, 10:27 AM   #5
fieldsbart is offline fieldsbart
diyAudio Member
 
Join Date: Feb 2015
I have a broken Ampeg svt-8 pro as well. I was wandering about the float circuit as well.
On mine j7 1st pin is - 127 2nd pin -108 and 3rd pin is -127, is that correct? I get signal up to the power amp
input ic10.
  Reply With Quote

Reply


Ampeg SVT-8 Pro Power Supply HelpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ampeg svt 3 pro Power Amp served Solid State 84 17th August 2017 10:50 PM
Help Ampeg SVT-3 Pro cowpoke Solid State 3 25th July 2011 10:06 PM
Any Ampeg SVT-II (non-pro) schematics??? spirus Instruments and Amps 15 30th May 2010 11:00 AM
ampeg svt 2 pro preamp problem unsolved Instruments and Amps 9 1st March 2010 07:55 PM
ampeg svt-3 pro schematic steven344 Solid State 0 23rd October 2006 12:09 PM


New To Site? Need Help?

All times are GMT. The time now is 10:19 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki