Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Instruments and Amps Everything that makes music, Especially including instrument amps.

Failing Marshall 8080
Failing Marshall 8080
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th October 2011, 02:54 AM   #1
RowdyRock is offline RowdyRock
diyAudio Member
 
Join Date: Oct 2011
Default Failing Marshall 8080

Have a 20yo Marshall 8080 been fine but plugged my fender strat and lost all power from the Boost Channel. Can finly hear the amp sound, but very little. The amp squeeled for a second after plugging in and then this. I presuem that means the tubes in the pwoer Amp have blown? Had similar happen a couple of years ago when I first bought the amp. Is it possible that the cable was faulty? Foudn an old cable that came with the Strat and havent used in years. Is it easy to chnage the tubes? last time cost me $400 and the amp woudlnt be woth that much anymore.
  Reply With Quote
Old 6th October 2011, 04:45 AM   #2
Gilgy is offline Gilgy  United Kingdom
diyAudio Member
 
Join Date: Oct 2009
I hate to break it to you but the Marshall 8080 doesn't use tubes in the power amp section. It hasa single 12AX7 (ECC83) in the preamp and a solid state power amp.

A bit of googling tells me that the 8080 only uses the preamp tube in the boost circuit ...

Marshall Amps :: The Secret Life Of Valves

... so if you're getting the squeal on all channels then it's not an issue with the preamp tube.
  Reply With Quote
Old 6th October 2011, 04:47 AM   #3
Gilgy is offline Gilgy  United Kingdom
diyAudio Member
 
Join Date: Oct 2009
Just re-reading your post, if someone charged you $400 to change the tubes then you need to find a better repair guy.
  Reply With Quote
Old 6th October 2011, 04:48 AM   #4
Gilgy is offline Gilgy  United Kingdom
diyAudio Member
 
Join Date: Oct 2009
ok, re-reading your post again you're getting a problem on the boost channel so yes, it could well be a problem with the preamp tube
  Reply With Quote
Old 6th October 2011, 12:11 PM   #5
costis_n is offline costis_n  Greece
diyAudio Member
 
Join Date: Aug 2008
400 to "change the tubes", considering there is only one chinese ECC83 in there? I am in the wrong business.
  Reply With Quote
Old 6th October 2011, 05:16 PM   #6
kevinkr is offline kevinkr  United States
diyAudio Moderator
 
kevinkr's Avatar
 
Join Date: Sep 2004
Location: Boston, Massachusetts
Failing Marshall 8080
Per FORUM policy I am moving this thread to I&A
__________________
"To argue with a person who has renounced the use of reason is like administering medicine to the dead." - Thomas Paine
  Reply With Quote
Old 7th October 2011, 12:35 AM   #7
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
It could easily be tube related. If the clean channel works OK, then the power amp must be OK.

The tube itself could have failed, or one of its power supplies. Are the heaters in the tube glowing? And there is a small high voltage supply just for the tube, make sure a resistor in it has not opened and that there is B+ on the tube plates.

Otherwise, apply a signal at the input and just trace it stage by stage through the bad channel.
  Reply With Quote
Old 7th October 2011, 02:14 AM   #8
nigelwright7557 is offline nigelwright7557  United Kingdom
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
ECC83 are very cheap I pay 3-50 for mine at RS components so its worth buying one to replace the possibly faulty one to try it.
__________________
PCBCAD51 pcb design software. 2018 version out now. https://www.ebay.co.uk/itm/253272755...84.m1555.l2649
  Reply With Quote
Old 15th October 2011, 07:00 PM   #9
basreflex is offline basreflex  Spain
diyAudio Member
 
Join Date: Oct 2007
I'm currently working on a valvestate 8080 right now. It apparently fell on its nose, as most of the pots were open or intermittent. tubeampdoctor has them in stock.
  Reply With Quote
Old 17th October 2011, 09:29 AM   #10
Nigel Goodwin is offline Nigel Goodwin  England
diyAudio Member
 
Join Date: Jul 2005
Location: North Derbyshire
Quote:
Originally Posted by basreflex View Post
I'm currently working on a valvestate 8080 right now. It apparently fell on its nose, as most of the pots were open or intermittent. tubeampdoctor has them in stock.
I repaired a mixer for a lady singer, it had a large number of broken pot's - with the ones in the middle broken the worst. Once I'd found all the broken ones, it was obvious that it had been hit by a football - it was a perfect circular pattern, with the very centre ones damaged most.

It turned out she kept it in her conservatory, and has a young son who likes to play football
__________________
Nigel Goodwin
  Reply With Quote

Reply


Failing Marshall 8080Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
marshall valvestate 8080 hiss raw/growl meta11icafreak Instruments and Amps 8 10th July 2013 03:20 PM
Marshall Valvestate 8080 kdawg Instruments and Amps 10 1st May 2012 01:08 AM
Guitar amp problem (marshall 8080 valvestate) Palmu85 Instruments and Amps 3 26th September 2011 10:33 PM
Marshall 8080-Channel select button problem tommy12 Instruments and Amps 2 10th November 2010 11:10 AM
marshall valvestate 8080 repair tips needed skid Instruments and Amps 4 25th April 2006 02:01 PM


New To Site? Need Help?

All times are GMT. The time now is 06:55 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki