Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Instruments and Amps Everything that makes music, Especially including instrument amps.

Peavey valveking 112 lead (distortion) channel doesn't work
Peavey valveking 112 lead (distortion) channel doesn't work
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th August 2011, 08:01 PM   #1
Gilberty23 is offline Gilberty23
diyAudio Member
 
Join Date: Aug 2011
Default Peavey valveking 112 lead (distortion) channel doesn't work

I've got a valveking 112 and a lead channel stopped working.(clean channel is working fine on 100%). I've replaced all the tubes but the problem still persist.I've searched for cold joint, got the suspicious ones resoldered but it didn't helped . Can anybody help me out with this, please?
  Reply With Quote
Old 16th August 2011, 12:04 AM   #2
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
I responded to this over in either SS Guitar or the PV forum. Check voltages around V2, and then trace signal trough the V2 circuits.
  Reply With Quote

Reply


Peavey valveking 112 lead (distortion) channel doesn't workHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Peavey Valveking 100- static sound during warm-up Rotus623 Instruments and Amps 80 6th December 2010 03:16 PM
Peavey Valveking 112 Combo SCHEMATIC vangelis Instruments and Amps 7 13th July 2010 03:09 PM
Peavey Valve King 112 jeppix Instruments and Amps 4 8th February 2010 03:19 AM
Peavey 8.5C DeAd cHaNnEl Pbassred Instruments and Amps 3 9th May 2005 11:44 PM
channel distortion sriegel Pass Labs 15 13th February 2002 06:23 PM


New To Site? Need Help?

All times are GMT. The time now is 04:17 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki