Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Instruments and Amps Everything that makes music, Especially including instrument amps.

Peavy windsor tube head issue
Peavy windsor tube head issue
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st September 2010, 02:15 AM   #1
rockster363 is offline rockster363
diyAudio Member
 
Join Date: Sep 2010
Default Peavy windsor tube head issue

So i straight traded a guy my fender hot rod deluxe for a peavy windsor tube head and cab off craigslist. as expected, I'v discovered an issue with the one of the tubes. One of my el34 power tubes is not glowing at all when in use.

So i figure well thats gotta be wrong? no issue with sound at all, or volume seems fine but i dont really know much about how loud a 100watt tube amp can go so not sure if there is a difference at all.

So what do i do? investigate!

Pulled the tube out and inspected it. seems fine, but not sure.

I'm wondering a couple things. if its the tube thats bad, i know i'll have to replace the whole set of four, but if its not, how would i go about trouble shooting.

BTW, i opened the whole thing up and found that the solder points seem a little jacked. about to reheat and confirm good connections to the points on that particular tube socket before i put it all back together...anyways, thanks for the help in advance!

Eric
  Reply With Quote
Old 21st September 2010, 02:48 AM   #2
Wavebourn is offline Wavebourn  United States
Designer & Technologist
diyAudio Member
 
Wavebourn's Avatar
 
Join Date: Sep 2006
Location: Pleasant Hill, CA
Peavy windsor tube head issue
Hi Eric;
it is easy to swap toobs to check if another toob in the same socket will work, or not.
__________________
The Devil is not so terrible as his math model is!
  Reply With Quote
Old 21st September 2010, 03:04 AM   #3
rockster363 is offline rockster363
diyAudio Member
 
Join Date: Sep 2010
Ahhh i didn't know that was okay to do! It wont affect the bias will it?
and just to let you know, its a bad el34. Easy fix, new tubes and a bias.
Thanks for letting me know that! i had no idea it was okay to swap them out.
  Reply With Quote
Old 21st September 2010, 03:50 AM   #4
Wavebourn is offline Wavebourn  United States
Designer & Technologist
diyAudio Member
 
Wavebourn's Avatar
 
Join Date: Sep 2006
Location: Pleasant Hill, CA
Peavy windsor tube head issue
You said it is a matched quad, so what is the difference in which socket to insert one of matched tubes, right?
__________________
The Devil is not so terrible as his math model is!
  Reply With Quote
Old 21st September 2010, 04:18 AM   #5
kenpeter is offline kenpeter  United States
diyAudio Member
 
Join Date: Nov 2007
Location: Dallas
Schematic I'm looking at shows no cathode bias resistors whatsoever... 100% fixed bias.
So, I suspect you could gank an EL34 off the opposite side to restore a current balance.
Temporary fix only... You would obviously lose half your power. But I don't see anything
that requires a drastic rebias onna-counta-gankage.

EL34, KT77, 6CA7: all the same tube more or less... Whats that in Ruskie part number?
6п27C, 6P27S: compatible, or different? This part number finds very little reference...

6L6/KT66 will also fit the hole, but the re-bias would be drastic for sure. Not something
to wing without a plan. Don't mix with EL34. Also tone more neutral, less "Marshally".

http://www.parts-express.com/pe/show...umber=248-8834
A variety pack of tube types likely to work. I don't know any Windsor self bias class A?
I suspect you change the tube type, you gotta re-bias, else end of story...

Last edited by kenpeter; 21st September 2010 at 04:48 AM.
  Reply With Quote
Old 21st September 2010, 06:42 AM   #6
Wavebourn is offline Wavebourn  United States
Designer & Technologist
diyAudio Member
 
Wavebourn's Avatar
 
Join Date: Sep 2006
Location: Pleasant Hill, CA
Peavy windsor tube head issue
Yes, 6П27С is compatible with EL34.
__________________
The Devil is not so terrible as his math model is!
  Reply With Quote

Reply


Peavy windsor tube head issueHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Peavey Windsor 120 Watt head schematic? guitar_joe Instruments and Amps 17 14th September 2016 10:28 AM
Weird issue with tube driver. 807tubenut Tubes / Valves 17 15th September 2010 01:19 AM
FS Firstone tube head preamp hamish_gill Swap Meet 0 11th April 2009 04:39 PM
Will someone please help me find a pedal schematic for a peavy amp galamoth Instruments and Amps 0 26th November 2006 08:41 PM
Ultimate Tube head phone amp. tube-lover Tubes / Valves 14 13th July 2005 05:25 PM


New To Site? Need Help?

All times are GMT. The time now is 02:43 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki