Bass amp with Audiopower DPA-600/F (sad story) - diyAudio
Go Back   Home > Forums > Live Sound > Instruments and Amps
Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Instruments and Amps Everything that makes music, Especially including instrument amps.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th January 2017, 02:33 PM   #1
diyAudio Member
 
Join Date: Sep 2005
Location: Tuscany, Italy
Default Bass amp with Audiopower DPA-600/F (sad story)

Hi,
in December 2015 I bought a class D module "DPA-600/F" from Audiopower (Audio Power | Professional Audio Equipment) to build my own amp bass (I'm a bassist and a diy-er) and have a light amp to carry for my gig.
I equipped this amp with a simple preamplifier (no tone controls, my bass is active) that I built time ago using an OPA2132 (non-inverting configuration).
Since the DPA-600 provided onboard power (+/- 15V, 250 mA) for external boards I used those outputs to power the preamp.
Everything has worked very well till March 2016 when suddenly the DPA-600 went into protection and some smoke got out from the case.
Then I contacted Audiopower and sent the DPA-600 to be fixed: one of the voltage stabilizer broke down due to my preamp, they told me.
It was strange for me since the preamp is really simple and I've used it in other projects without problems but I took their advice to disconnect the preamp from the DPA..and so I did (the repairing costed me 50 Euro, anyway).
I built then a separated power supply and everything has worked well till last december when after 10 minutes of playing (on a gig) it went into protection and after a few secs turned off dead !!
Fortunately the bassist of the other band (we were two bands) gave me his amp head so I was able to continue the gig.
The loudspeaker was the same for us bassists (1x15", it was mine loudspeaker) so I can exclude that the cause of the DPA-600 fault was the loudspeaker.
In December, 21 I contacted Audiopower support through email but I've got no reply.
I thought that maybe they were closed for XMas holidays so I wrote them again last Jan, 11 but I've got no reply so far.
Ok...I'm not certainly a big customer but I don't like to waste my money (210 Euro, including the repairing), the most irritating thing is not to get any reply from them.
So I had to buy a new amp (a TC Electronic BH800) since I have several gigs in the next weeks and I had no other amp.
I will wait for their reply for a few days more and then, if I won't have any contact from them, I will decide what to do.
How can I say? It's really a pity.
Regards,


Roberto

Last edited by washburn_it; 11th January 2017 at 02:58 PM.
  Reply With Quote
Old 11th January 2017, 03:00 PM   #2
denbret is offline denbret  Canada
diyAudio Member
 
denbret's Avatar
 
Join Date: Mar 2011
Location: St-Jean-Richelieu
Hi, on our forum in canada, we expelled this manufacturer from the forum, as several members had no reply from their amps for repair.
  Reply With Quote
Old 11th January 2017, 03:05 PM   #3
diyAudio Member
 
Join Date: Sep 2005
Location: Tuscany, Italy
I didn't know that...was it maybe "Quebec DIY"?
  Reply With Quote
Old 11th January 2017, 03:15 PM   #4
denbret is offline denbret  Canada
diyAudio Member
 
denbret's Avatar
 
Join Date: Mar 2011
Location: St-Jean-Richelieu
I can not write the name of the forum, in order to avoid being sued.

Some members had been waiting for almost a year. And they sent dozens of email.
  Reply With Quote
Old 11th January 2017, 03:27 PM   #5
diyAudio Member
 
Join Date: Sep 2005
Location: Tuscany, Italy
Very sad...nobody of them had a reply from Audiopower?
  Reply With Quote
Old 11th January 2017, 04:33 PM   #6
denbret is offline denbret  Canada
diyAudio Member
 
denbret's Avatar
 
Join Date: Mar 2011
Location: St-Jean-Richelieu
Yes sometimes, with promises of style, it is after tomorrow or it is in the post, this time it is really ..
  Reply With Quote
Old 12th January 2017, 08:47 AM   #7
diyAudio Member
 
Join Date: Sep 2005
Location: Tuscany, Italy
Well...you won't believe it but today I've received their reply...they have problems with their provider internet that blocked their email address "support" and "sales" where I sent my messages.
So maybe there will be a "happy ending"...I will let you know.
Regards,


Roberto
  Reply With Quote
Old 12th January 2017, 01:22 PM   #8
denbret is offline denbret  Canada
diyAudio Member
 
denbret's Avatar
 
Join Date: Mar 2011
Location: St-Jean-Richelieu
This excuse from the internet provider is not new.

good luck.
  Reply With Quote
Old 14th January 2017, 10:21 AM   #9
nono112 is offline nono112  France
diyAudio Member
 
Join Date: Oct 2016
Location: Beauvais
Good morning,
I have the same problem as you with audiopower.
I sent 2 amplifiers (1 MDA400 and 1 DPA 600) learned on September 19, 2016.
Stefania promised me a repair in eight days.
We are January 14, 2017 I received full of promises and lies from Stefania and Roberto PUPELLA but I still do not have my amps.
Monday by a formal notice to do with registration to the competent court of my country.
If not answered by them will be prosecuted before the judge.
Good luck and good luck to recover your DPA 600.
expect multiple apologies and promises to be just lies ...........
  Reply With Quote
Old 14th January 2017, 11:46 AM   #10
diyAudio Member
 
Join Date: Oct 2012
hope you succeed with the company.
in the mean time this may be helpful to you with respect to amp module choice Guitar Amplifiers
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AudioPower (DPA-400) Sound pressure improvements? AP2 Class D 83 3rd October 2013 10:26 AM
AudioPower DPA-400/F-3 Listening impressions, tips & tricks... Stefany Vendor's Bazaar 5 26th April 2013 08:41 AM
avoid resonances - a sad story diymax62 Multi-Way 20 18th October 2007 01:27 PM
OT: Sad story... will make you sad.. don't read it! KBK Everything Else 1 8th February 2004 08:43 PM
A sad Story Shoog Pass Labs 10 10th September 2002 08:50 PM


New To Site? Need Help?

All times are GMT. The time now is 09:36 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright 1999-2017 diyAudio

Content Relevant URLs by vBSEO 3.3.2
Wiki