Skytec TEC 6950 Help - diyAudio
Go Back   Home > Forums > Live Sound > Instruments and Amps

Instruments and Amps Everything that makes music, Especially including instrument amps.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st February 2014, 02:25 PM   #1
Rick55 is offline Rick55  United Kingdom
diyAudio Member
 
Join Date: Feb 2014
Default Skytec TEC 6950 Help

i have a tec 6950 amp and i know its a china clone but was hoping someone out there could help and locate a full schematic, it is rated at 500 watt!!!.

The fault is no outputs so i would like a manual/schematic before i strip it.

I have not started anything on it yet apart from taking the top off to take the picture of the inside.

Any help appreciated.

Apologies for picture quality
Attached Images
File Type: jpg Skytec 001.jpg (451.1 KB, 23 views)
  Reply With Quote
Old 24th February 2014, 05:03 PM   #2
Rick55 is offline Rick55  United Kingdom
diyAudio Member
 
Join Date: Feb 2014
a littel more info , on the volume pcb there is a burned up resistor R1, has anyone come acroos this and any help as to its value would be appreciated, the TEC6950 has other models in the range, 6200, 6300, 6500 so a schematic for these might cover this model.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inputs not working on skytec pro 240 amp stuart1976 Solid State 2 17th March 2011 11:22 PM
Skytec PRO240 blown output - circuit diagram? David Pinnegar Solid State 5 17th March 2011 11:20 PM
no output on skytec pro 240 amp stuart1976 Analog Line Level 2 17th March 2011 03:51 PM
skytec 6950 amp wrong specs on manual joka22 Solid State 0 15th July 2007 09:51 PM
help on param. for skytec 902.357 psychosteve Multi-Way 0 2nd November 2004 02:43 PM


New To Site? Need Help?

All times are GMT. The time now is 02:22 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2