Trace Elliot AH300-7 power issues Help - diyAudio
Go Back   Home > Forums > Live Sound > Instruments and Amps

Instruments and Amps Everything that makes music, Especially including instrument amps.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd October 2012, 01:56 PM   #1
diyAudio Member
 
Join Date: Oct 2012
Default Trace Elliot AH300-7 power issues Help

I have a Trace Elliot AH300-7 that I just bought used. Everything on it has been working fine until yesterday's practice.

In the middle of playing the sound cut out on it. The front lights, light up and the power switch in the back is lit up as if it is on. The fan does not spin now and there is no sound coming out of the amp. Bandmates think it could be a fuse, I pulled it but it is not a clear fuse so I cannot tell if it is blown. It is white.

Off to try and find a fuse today. Anyone have any ideas if it could be something else? I have searched Google all last night and this morning and can't find an answer. Any help is appreciated.
  Reply With Quote
Old 24th October 2012, 08:26 PM   #2
Struth is offline Struth  Canada
diyAudio Member
 
Join Date: Aug 2012
Location: books at londonpower.com
Hi Guys

Try another fuse but do not use a higher value than originally specified. If it blows too then take the amp to a qualified tech. This amp has higher voltages than typical guitar ad bass amps - 7-800V compared to 500V - high enough to be lethal!

Like most 6550 amps, this one has low-value screen resistors that should be replaced with 1k-5W each. This will keep the amp from eating tubes.

Always make sure there is lots of air flow around the amp. You cannot rely entirely on the fan to keep it cool.

Have fun
Kevin O'Connor
londonpower.com
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TRace Elliot AH500-7 zenelectro Instruments and Amps 6 2nd January 2014 08:57 PM
Trace Elliot BOCHIN Solid State 12 13th August 2012 04:05 PM
TRACE ELLIOT ... east electronics Solid State 1 9th September 2011 02:02 PM
Trace Elliot Tube replacment jahash Tubes / Valves 1 18th April 2008 07:26 AM
Trace elliot ppa 600 eaream Solid State 2 5th February 2004 08:59 AM


New To Site? Need Help?

All times are GMT. The time now is 11:41 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2