Recording into a macbook (distortion but no peaking) - diyAudio
Go Back   Home > Forums > Live Sound > Instruments and Amps

Instruments and Amps Everything that makes music, Especially including instrument amps.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd March 2012, 05:47 PM   #1
diyAudio Member
 
Join Date: Nov 2011
Location: US
Default Recording into a macbook (distortion but no peaking)

I have built a nice little circuit that runs from the speaker output to my laptop input. There is a 100W resistor dissipating the power from the amp. I use an isolation transformer after stepping down the voltage to isolate the amp and computer's ground from each other. The signal is about 2-4V at the secondary of the transformer (not noisy at all). I use some more resistance to step the signal down to 1V or so to run into my computer. I have the mic input volume on maximum and when I play through the amp, it does not peak out. However, there is a significant amount of distortion when I play loud (still not peaking).
Any suggestions? I was told by a professor that 1V, 600 Ohms was the standard for audio input.
  Reply With Quote
Old 23rd March 2012, 07:01 PM   #2
diyAudio Member
 
Join Date: Jun 2011
Sounds like you haven't really got a clue as to what you're doing.

Forget the transformer.

Look up 'voltage divider' on Wikipedia. Make Z1 1k and Z2 100R. You'll need one pair for left and one for right. Turn down the amplifier volume if necessary.

Use the battery when recording, although chances are that the computer's brick supply is isolated anyway. You can check this with a DMM. See if there is continuity from any of the mains plug pins to either side of the DC jack.

If you keep the amp turned down to ~10V peak, you can use quarter watt resistors. To put it another way, turn it down if they start to smoke

Last edited by counter culture; 23rd March 2012 at 07:21 PM.
  Reply With Quote
Old 23rd March 2012, 07:54 PM   #3
cbdb is offline cbdb  Canada
diyAudio Member
 
Join Date: Oct 2008
Location: Vancouver
Quote:
I was told by a professor that 1V, 600 Ohms was the standard for audio input.
Thats not a very good answer. There are a few "standards" for audio. For professional equipment the line level is +4 dbu (around 1 volt) for nominal level, for consumer gear its -10 dbu or about 200mv (but can vary quite a bit)and for mic inputs its anywhere from -60dbu to -20dbu. The 600ohms is for mic inputs only, and that can vary also, line inputs are usually around 50k ohms. These are nominal levels which dont include headroom, which is typically another 10 to 20 db, so the actual signal the input can handle is 20db hotter than the 200mv (for consumer gear ) or around 2 volts. (Unfortunately the loudness wars have pushed the normal level of CDs so high there is no such thing as headroom anymore.)

The macbook inputs are line level ( i cant find any exact numbers) probably consumer level. And no telling how much headroom they have.

Do what counter culture said and then use the mac meter to set the amp volume so the meter tops out a couple of segments below the max.

Last edited by cbdb; 23rd March 2012 at 08:10 PM.
  Reply With Quote
Old 23rd March 2012, 07:57 PM   #4
diyAudio Member
 
Join Date: Nov 2011
Location: US
With all due respect, I wouldn't have attempted to hook thousands of dollars worth of equipment together without putting some thought into this, or without knowing what a voltage divider was. The circuit replaces the speaker cabinet, so even if I used higher resistances rated at a quarter watt, the power from the amp has to go somewhere or the amp gets damaged. The goal is to silently record out of my half stack (which really only sounds decent at high volumes). The transformer handles audio frequencies quite well and isn't doing any harm, a small price to pay on the off chance that there is a ground loop. The amp is in mono, so I only need to worry about one channel.

The question was about noise at the input jack. If I have adressed any concerns of signal impedance, is there some other reason why the signal is distorting even though it reports no peaking.

Thank you for your response.
  Reply With Quote
Old 23rd March 2012, 08:00 PM   #5
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England


Thread moved to appropriate area.
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 23rd March 2012, 08:03 PM   #6
diyAudio Moderator
 
pinkmouse's Avatar
 
Join Date: Apr 2002
Location: Chatham, England
Quote:
Originally Posted by Littlebilly91 View Post
If I have adressed any concerns of signal impedance, is there some other reason why the signal is distorting even though it reports no peaking.
Are you sure you're not just hearing the amp distortion?
__________________
Rick: Oh Cliff / Sometimes it must be difficult not to feel as if / You really are a cliff / when fascists keep trying to push you over it! / Are they the lemmings / Or are you, Cliff? / Or are you Cliff?
  Reply With Quote
Old 23rd March 2012, 08:38 PM   #7
diyAudio Member
 
Join Date: Nov 2011
Location: US
I know the distortion is coming from the computer. My setup is keyboard->amp->circuit->computer. My computer seems to be switching between two 'modes' (for lack of a better word). In one mode, the signal input appears quiet, peaking around -10dB. It distorts when I hit the keys hard. Without touching my circuit or amp, the computer will switch to a second mode (I don't know what causes it) where the signal looks as I would expect it to, meaning that it does peak out a little on loud notes (and only then it distorts) and the overall sound is much louder. It is almost as if the computer is preparing itself for two different kinds of inputs and it is switching between the two kinds on its own. Has anyone experienced this?
  Reply With Quote
Old 23rd March 2012, 09:11 PM   #8
diyAudio Member
 
Join Date: Jun 2011
LOL.

These are the symptoms of a bad joint, almost certainly in your 'circuit', but it could be anywhere right up to the input jack on the laptop.

If you told us what value resistors you're using and which transformer there might be some hope of telling what's going on. You haven't even told us how the parts are connected.

As it is, you can leave the 100W resistor loading the output and use a resistive divider as I have suggested. Most solid-state amplifiers will work fine without the loading though.

A transformer is just looking for trouble, however. There are just so many wrong transformers you could pick and none that are intended for this purpose. If you want DC isolation, use a capacitor. You'll have to get somebody with more patience than I to explain how to dimension and select it though. Better still, use the battery or check the PSU.
  Reply With Quote
Old 23rd March 2012, 09:22 PM   #9
diyAudio Member
 
Join Date: Dec 2003
Location: Orange County, CA
You still have far too much voltage going into the Mac. A 100W resistor connected in series with the input is useless unless it is part of a voltage divider. Instead a 15K and a 220 ohm resistor, both 1/4W will do fine with the Macbook connected across the 220 ohm resistor. Also note that the Macbook needs only about 100mV of signal to work on its line level audio input.

Or you may just want to get a speaker to line level converter box like the Radial JDX
__________________
Dan Fraser
  Reply With Quote
Old 23rd March 2012, 09:51 PM   #10
cbdb is offline cbdb  Canada
diyAudio Member
 
Join Date: Oct 2008
Location: Vancouver
Quote:
The circuit replaces the speaker cabinet, so even if I used higher resistances rated at a quarter watt, the power from the amp has to go somewhere or the amp gets damaged. The goal is to silently record out of my half stack (which really only sounds decent at high volumes). The transformer handles audio frequencies quite well and isn't doing any harm, a small price to pay on the off chance that there is a ground loop.
First of all, can you get at the signal pre poweramp and put a line level signal into the mac? (and not add the amps distortion and noise to your recording)

Unless your amp is a TUBE AMP no load will not damage your amp. The way your speakers only sound good at high levels has nothing to do with the way the amp sound at low levels (most SS class A/B amps will actually sound better at low levels while they are still in class A (unless noise is an issue). Get rid of the transformer, it wont improve anything (except isolation) which you probably wont need. Try it , if you get a ground hum (60hz + harmonics) run the mac of the battery.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hornresp for MacBook weltersys Subwoofers 11 16th February 2011 12:40 AM
Recording, playbackís poor relation? Post a DIY recording. wakibaki The Lounge 4 2nd December 2010 04:46 AM
corrections for LF and HF peaking pdcaceo Tubes / Valves 4 14th November 2010 12:58 PM
Do you own a MacBook? haulin79 The Lounge 3 29th July 2010 07:43 AM


New To Site? Need Help?

All times are GMT. The time now is 02:24 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2