Marshall 8080-Channel select button problem - diyAudio
Go Back   Home > Forums > Live Sound > Instruments and Amps

Instruments and Amps Everything that makes music, Especially including instrument amps.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th November 2010, 11:21 AM   #1
diyAudio Member
 
Join Date: Nov 2010
Default Marshall 8080-Channel select button problem

Hi there,

I have a Marshall Valvestate 80v - Model 8080.
The channel select button from Normal channel To Boost channel is sometimes jumping from one to another, it usualy happens when i play some time (Maybe heat problem ?). But it usualy happens from Clean to Boost as long as i can remember.

Here is an image of the amp and this button.
Click the image to open in full size.

What can be the problem ?

Thanks

Tommy
  Reply With Quote
Old 10th November 2010, 03:48 AM   #2
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
The switch contacts can be dirty, the solder under the switch can be cracked, the switch can be mechanically failing, there can be a problem with the power supply to that circuit. TR1, TR2 could be going leaky.
  Reply With Quote
Old 10th November 2010, 11:10 AM   #3
diyAudio Member
 
Join Date: Nov 2010
Thanks,
I gave the amp to a technician and he said that every thing is O.K. with this switch, but i don't think he is a good technician.
I already paid him and i have warranty so i'm hoping he know how to repair it.
I asked the question in order to know better and if it's necessary i'll ask him if he checked this options.

I already have regrets for not going to a well known technician.

Thanks for helping

Tommy
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
marshall valvestate 8080 hiss raw/growl meta11icafreak Instruments and Amps 8 10th July 2013 03:20 PM
Marshall Valvestate 8080 kdawg Instruments and Amps 10 1st May 2012 01:08 AM
Guitar amp problem (marshall 8080 valvestate) Palmu85 Instruments and Amps 3 26th September 2011 10:33 PM
Marshall Valvestate 8080 low gain on Boost Channel mgjimbo Solid State 0 28th May 2008 03:04 AM
marshall valvestate 8080 repair tips needed skid Instruments and Amps 4 25th April 2006 02:01 PM


New To Site? Need Help?

All times are GMT. The time now is 06:18 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2