Marshall AVT50 Pops when Switching Channels - diyAudio
Go Back   Home > Forums > Live Sound > Instruments and Amps

Instruments and Amps Everything that makes music, Especially including instrument amps.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th September 2010, 08:01 PM   #1
morta is offline morta  United States
diyAudio Member
 
Join Date: Aug 2010
Default Marshall AVT50 Pops when Switching Channels

Folks, I have a Marshall AVT50 that makes a very LOUD popping noise when I switch between channels. I see a few other occasions of this issue on the net, but haven't seen any solution - probibly didn't look in he right places... Has anyone else experienced this issue and maybe has come accross a fix? Thanks, Al
  Reply With Quote
Old 28th September 2010, 11:59 PM   #2
morta is offline morta  United States
diyAudio Member
 
Join Date: Aug 2010
Default clarification

Folks, Two points of clarification on this...

1. The noise it makes is actually a dramatic, momentary, increase in volume vs. a "pop", and
2. This occurs both when switching the channel selector on the face of the Amp and also using the Footswitch


Thanks for any pointers you can offer..... Al
  Reply With Quote
Old 7th October 2010, 04:13 AM   #3
diyAudio Member
 
gain wire's Avatar
 
Join Date: Nov 2004
Location: NCR
Well, the first thing that comes to mind is dirty relay contacts.

however if this amplifier uses JFETs to switch between channels, then it might just be a loose connection or component somewhere in the channel switching circuit. You'll have to take it apart and measure some voltages. And try to write to Marshall for a schematic, you'll need one.

cheers
__________________
Trans-directional-servo-logamp non-zerocrossing autogain compressing thingamajig
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marshall AVT50 Mods JakeAC5253 Solid State 5 25th December 2012 06:26 PM
Switching between preamp channels (Sansamp GT2 based) ? danV Instruments and Amps 3 19th October 2011 02:11 AM
Getting better EQ on a Marshall AVT50 Fr_3_aK Instruments and Amps 15 3rd January 2009 10:01 AM
MARSHALL AVT50 mod. Vahagn Instruments and Amps 4 28th January 2006 06:52 PM
switching channels 9am53 Instruments and Amps 9 9th June 2005 04:14 AM


New To Site? Need Help?

All times are GMT. The time now is 05:38 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2