Studiomaster 16-16-2 schematic - diyAudio
Go Back   Home > Forums > Live Sound > Instruments and Amps

Instruments and Amps Everything that makes music, Especially including instrument amps.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th August 2010, 12:52 AM   #1
diyAudio Member
 
chitownrocker's Avatar
 
Join Date: Aug 2010
Location: Elgin,il U.S.A
Default Studiomaster 16-16-2 schematic

Hi all, Looking for a schematic for a studiomaster 16-16-2. What i am looking for mostly is the power supply. Thanks.

Doug
  Reply With Quote
Old 11th August 2010, 12:34 PM   #2
diyAudio Member
 
chitownrocker's Avatar
 
Join Date: Aug 2010
Location: Elgin,il U.S.A
Well i got the board open, and the power supply is disconnected?
__________________
To the world, you may be just one person.
But to one person, you may be the world.
  Reply With Quote
Old 11th August 2010, 01:41 PM   #3
diyAudio Member
 
chitownrocker's Avatar
 
Join Date: Aug 2010
Location: Elgin,il U.S.A
But the wires to the terminals for the power supply cord are broken and disconnected, so any help in finding a schematic, would be greatly appricated.

Doug
__________________
To the world, you may be just one person.
But to one person, you may be the world.
  Reply With Quote
Old 11th August 2010, 09:31 PM   #4
diyAudio Member
 
chitownrocker's Avatar
 
Join Date: Aug 2010
Location: Elgin,il U.S.A
Unhappy Pics

Well I'm including some pics so maybe someone has mercy on me (lol). They are of both my Studiomaster 16-4-2 (working) and the new Studiomaster 16-16-2 (not working) Arrrrrr....

Wish me luck!!!
Attached Images
File Type: jpg 100_4131.JPG (576.1 KB, 347 views)
File Type: jpg 100_4132.JPG (386.9 KB, 253 views)
File Type: jpg 100_4133.JPG (479.7 KB, 244 views)
File Type: jpg 100_4134.JPG (834.6 KB, 241 views)
File Type: jpg 100_4135.JPG (700.9 KB, 235 views)
File Type: jpg 100_4136.JPG (885.3 KB, 89 views)
__________________
To the world, you may be just one person.
But to one person, you may be the world.
  Reply With Quote
Old 13th August 2010, 11:57 AM   #5
diyAudio Member
 
chitownrocker's Avatar
 
Join Date: Aug 2010
Location: Elgin,il U.S.A
Default Got it working W/one board disconnected

Well folks i got the Monster working, using my 16-4-2 and the schematic from a simular studiomaster boards p/s. Check out the pictures of the power cable vice-gripped to the board (Too Funny). BTW i don't recommend anyone doing this its very dangerous, and was only for the test.After i power the board up, the real problem appeared, channel #6 has a fried (burnt & cracked) Portugal TLO72 CP 319XB chip. So i disconnected board#6, and powered up the unit again, and after being on and testing all the channels for about 20 minutes. Its working again.

So now i will need to replace the TLO72, and start checking all the other parts on the board.My guess is a couple of bad caps and or ressistors.

DougVice gripped power cord.jpg

Close up.jpg

All led lit up.jpg
__________________
To the world, you may be just one person.
But to one person, you may be the world.
  Reply With Quote
Old 20th August 2010, 04:09 PM   #6
diyAudio Member
 
chitownrocker's Avatar
 
Join Date: Aug 2010
Location: Elgin,il U.S.A
Default Update LED'S out...

Ok so board #6 is fixed #15 fader was installed backwards (Fixed). And now all the L.E.D's are disconnected, and let me tee you folks, there a pain to get to. Ive included a pic of board #6 befor the fix. Digikey part#296-1775-5-ND. Enjoy...
Attached Images
File Type: jpg 100_4149.JPG (678.9 KB, 113 views)
__________________
To the world, you may be just one person.
But to one person, you may be the world.

Last edited by chitownrocker; 20th August 2010 at 04:11 PM. Reason: pic
  Reply With Quote
Old 11th November 2010, 10:54 PM   #7
diyAudio Member
 
Join Date: Nov 2010
Default Studiomaster Series 5 16-4-2

Hi there
You are the only person on the net that i can find that also has (and obviously knows the workings of) one of these mixers.
I have posted on another forum which i would be very grateful if you could take the time to look at:

http://www.soundonsound.com/forum/sh...fpart=1#873374

Hopefully you can help me get this fantastic mixer going again, i would be very grateful
  Reply With Quote
Old 19th May 2011, 10:00 AM   #8
diyAudio Member
 
Join Date: May 2011
i wonder if you can help me,i have a studiomaster 16 16 2 desk,but sadly this got damp, this has been dryed out, and now when i power it up it all lights up ,but the mixer is dead, is there a internal fuse somewere,i have read its on the right hand side where the power cable goes in,but its not on mine. any help thank you
  Reply With Quote
Old 22nd January 2012, 12:27 AM   #9
diyAudio Member
 
Join Date: Dec 2011
Hello guys,

I have a Studiomaster 16-16-2 mixtable and finally (after 3 years) I have found a site were we can find a user manual as also a service manual of this type mixer.
The most of the info is usefull for more mixtables from the Studiomaster serie II.
Even there is a diagram from the power unit EP3 for this mixertable.
So look at www.dancetech.com sign in and look around, you will find a lot where you looking for

greetings from the Netherlands,
Willemradio.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BD139-16 & BD140-16? Anyone use these transistors? grhughes Parts 44 29th September 2013 09:56 AM
wanted: Marantz 16 schematic sparky813 Solid State 7 3rd September 2007 11:01 PM
Got a HK Citation 16 service manual or schematic? taj Solid State 11 12th June 2007 09:53 PM
schematic for h/k CITATION 16 / sixteen wingman Solid State 0 15th November 2004 07:44 PM
Schematic for HK Citation 16 G Solid State 36 27th February 2004 05:49 AM


New To Site? Need Help?

All times are GMT. The time now is 07:22 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2