Blue Voodoo Tube amp issue - diyAudio
Go Back   Home > Forums > Live Sound > Instruments and Amps

Instruments and Amps Everything that makes music, Especially including instrument amps.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd July 2008, 11:47 PM   #1
sasij is offline sasij  United States
diyAudio Member
 
Join Date: Jan 2008
Default Blue Voodoo Tube amp issue

Sorry if this isn't the right forum I was looking around and the "Tubes" section seemed more for building tube amps. I dunno if anyone can help me here but I came to this forum because its one of the only amp forums I know of.

My friend has a Crate Blue Voodoo 120 amp and its been working fine but recently the channel started switching itself. Like he will be playing through his pedal board using the clean channel and a distortion pedal and mid playing it will switch on the amps distortion channel out of no where. Obviously this causes it to sound like **** and it discourages him from playing. I was wondering if anyone has ever heard of anything like this or experienced it yourself on another amp. I'm simply trying to get ideas of why it would change itself mid playing when theres nothing hooked into the foot pedal switch in the back. If no one can help here I would appreciate if anyone could point me to a better forum for this question.

Thanks in advance.
  Reply With Quote
Old 24th July 2008, 11:51 AM   #2
diyAudio Member
 
Join Date: Jan 2006
Location: Poland
Have you tried to plug in anything (footswitch) into the jack in the back of the amp? The problem may be caused by non-contacting channel-switching jack. You may also ask at: http://music-electronics-forum.com/f...splay.php?f=22

Mark
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blue glow in tube. Is the tube dead or not? Pentium100 Tubes / Valves 37 22nd October 2009 06:45 PM
Blue Voodoo Solid State Rects to Tube Rects? Stryker11487 Tubes / Valves 9 4th June 2009 07:13 AM
FS: Butler Audio, tube driver blue 2ch amp *pics* shaunly Swap Meet 0 27th September 2006 06:56 AM
tube rolling Blue Circle BC 21 preamp sunseeker Tubes / Valves 0 27th February 2005 02:41 PM
Blue glowing tube Gabster Tubes / Valves 24 27th September 2002 04:08 AM


New To Site? Need Help?

All times are GMT. The time now is 08:58 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2