Buschhorn MkII w/ Foster W422, aka Fostex FE103A - Page 6 - diyAudio
Go Back   Home > Forums > Loudspeakers > Full Range

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th January 2009, 01:11 PM   #51
diyAudio Member
 
Join Date: Nov 2006
Location: Milan
Quote:
Originally posted by planet10


Similar niche drivers are measuring 87-89 dB. I expect that a factory fresh set was 91-92 dB.

dave
Thanks Dave. I feel better now.

Vale
  Reply With Quote
Old 10th April 2013, 03:56 AM   #52
diyAudio Member
 
Join Date: May 2007
Hello Vale,
Do you still have the Atomix drivers? f so, which cabinet did you build?
I have a pir of the Atomix 103 drivers with the alnico magnets. please let me know if you'd like to see some photos.
Cheers,
Dan
  Reply With Quote
Old 10th April 2013, 05:23 AM   #53
frugal-phile(tm)
diyAudio Moderator
 
planet10's Avatar
 
Join Date: Oct 2001
Location: Victoria, BC, NA, Sol III
Blog Entries: 5
Quote:
Originally Posted by danloani View Post
I have a pir of the Atomix 103 drivers with the alnico magnets. please let me know if you'd like to see some photos.
Yes we would Dan

dave
__________________
community sites t-linespeakers.org, frugal-horn.com, frugal-phile.com ........ commercial site planet10-HiFi
p10-hifi forum here at diyA
  Reply With Quote
Old 11th April 2013, 04:01 AM   #54
diyAudio Member
 
Join Date: May 2007
Default fe-103 type drivers

Hello,
Here are some photos of the fe-103 type drivers that I have. You mentioned that they may have been made by Atomix. They are marked W-422 / 8 Ohm / 2 watt / max 8 watt / full range / Japan. There are small, radial ribs on the cone. They sound very nice. I had to completely dismantle (destroy) the original cabinets in order to remove the drivers. I've had them mounted inside a nice pair of Realistic Solo 103 cabinets for safe keeping. Please feel free to email with questions or advice. Anyway, I hope the photo posting works.
Attached Images
File Type: jpg IMG_4204.jpg (883.6 KB, 44 views)
File Type: jpg IMG_4210.jpg (878.7 KB, 41 views)
File Type: jpg IMG_4208.jpg (829.5 KB, 37 views)
  Reply With Quote
Old 11th April 2013, 04:03 AM   #55
frugal-phile(tm)
diyAudio Moderator
 
planet10's Avatar
 
Join Date: Oct 2001
Location: Victoria, BC, NA, Sol III
Blog Entries: 5
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Foster FE103a: how to fix stiff treated cloth surrounds KT Full Range 7 25th September 2009 11:55 AM
Foster FE103A rca9449 Full Range 18 29th April 2008 05:59 PM
Buschhorn mkII Fuling Multi-Way 26 31st August 2004 07:39 PM


New To Site? Need Help?

All times are GMT. The time now is 05:07 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2